1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Frankenstein Swap On Del Sol, Many Problems

Discussion in 'HYBRID -> EG-EK / DC' started by oakley2002@cox.net, May 4, 2003.

  1. oakley2002@cox.net

    oakley2002@cox.net Junior Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Mar 23, 2003
    My friends and I tried to do a head swap over spring break... a d16z6 ported & polished head onto a d15b7 block. The car runs great, with the exception of it revs itself from 1500 to 1000 in idle, non-stop. I don't have the new computer yet, so that is what I've been told is the problem. Sound right?

    Now, it does run great.. but for a period about 4 minutes. From there it overheats! The car also seemed to be leaking coolant and oil, and it is burning a ton of coolant as is obvious by the constant stream of white smoke.

    Somehow we forgot to seal the copper head gasket, so we realized that was the problem. Yesterday my friend and I sealed the head gasket and re-sealed the others... ran great, then I reved it very lightly and it went back to ALL of its old ways.

    I took the spark plugs off this morning and there is a small amount of coolant on the first cylinder plug. I believe this is a new problem.

    Coolant is getting to the block, it was full when we took the head off. It isn't the temp gauge, as the engine is definately burning. We rigged the fan with a switch to keep it on constantly and that doesn't help at all.

    Any ideas would be greatly appreciated... we're stuck, and I'm starting to really worry about the car.
     
  2. Baker

    Baker Senior Member

    Messages:
    754
    Likes Received:
    0
    Joined:
    Oct 9, 2002
    Location:
    Schaumburg, IL
    if coolant is leaking into the engine you are completely screwed. stop driving it or running the car otherwise you will blow your motor
     
  3. vpSPOONsol

    vpSPOONsol Senior Member

    Messages:
    304
    Likes Received:
    0
    Joined:
    Apr 1, 2003
    Location:
    mildenhall village, england
    what ur doing is called a mini-me swap, a frankenstein swap is a ls-vtec swap...
     
  4. oakley2002@cox.net

    oakley2002@cox.net Junior Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Mar 23, 2003
    Oh, I was told that the mini-me was if you're going from any other d16 to a d16z6, and since I'm putting a d16 on a d15 it was called a frankenstein... didn't think that was right.

    I'm not running the car, thought we fixed it yesterday and took it for a ride to see and it was obviously not fixed... so it's now parked in the garage.

    Any ideas of the problem? People on other forums say copper head gaskets are crap... could that be why?
     
  5. Havok

    Havok Senior Member

    Messages:
    6,827
    Likes Received:
    1
    Joined:
    Sep 28, 2002
    Location:
    Florida
    It sounds like a bad head gasket, or you did something wrong related to the head gasket while swapping the head. Did you remove the oil jet on the block when you took off the D15B7?
     
  6. oakley2002@cox.net

    oakley2002@cox.net Junior Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Mar 23, 2003
    Yep, I was sure to remove the oil jet. I do have an extra head gasket for the D16z6 I will try as soon as I can; I thought it was the head gasket, too. I don't see what else it could be, but I don't really know much about engine problems.

    The d16z6 head does fit on the d15b7 block, doesn't it?
     
Verification:
Draft saved Draft deleted

Share This Page