1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

freaky thing

Discussion in 'General Tech and Maintenance' started by dragntoys, Jun 6, 2004.

  1. dragntoys

    dragntoys Member

    Messages:
    52
    Likes Received:
    0
    Joined:
    Mar 16, 2004
    while driveing to work the other day the skid plate came loose on the pass side of my crx si while it was flapping in the wind it unscrewed the radiator drain petcock
    and drained my radiator i have no temp gauge since i had blue face guages installed so i blew the head gasket well i changed the head gasket
    car still seems to be running hot i pluged the temp gauge back in and it reads red
    so i changed water pump no good still acts like it is running hot
    there is no water in my oil and it is not loseing water out of the radiator
    no steam out of tail pipe any help??????
     
  2. MikeBergy

    MikeBergy Blah blah blah....

    Messages:
    3,646
    Likes Received:
    1
    Joined:
    Oct 9, 2003
    Location:
    Central Coast, CALI
    did you bleed the coolant system when you filled it up? THat might be causing to to run a little warm.
     
  3. hcivic.com

    hcivic.com Senior Member

    Messages:
    4,571
    Likes Received:
    2
    Joined:
    Jan 7, 2003
    Location:
    Calgary Alberta canada
    are you runnig coolant or straight water and did you cange your themostat after you over heat it fucks them
     
  4. dragntoys

    dragntoys Member

    Messages:
    52
    Likes Received:
    0
    Joined:
    Mar 16, 2004
    coolant and changed thermastat and temp sensor
     
  5. MXDesa

    MXDesa Senior Member

    Messages:
    927
    Likes Received:
    2
    Joined:
    Apr 19, 2003
    Location:
    Queens, New York
    Is there oil in your coolant? And are you sure there is no coolant in your oil? It sounds like to me that you might have warped your head.
     
  6. JDMG2i

    JDMG2i Junior Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    May 3, 2004
    See if your fan is turning on you might want to run it to a swicth
     
Verification:
Draft saved Draft deleted

Share This Page