1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Guys I need help

Discussion in 'ECU's, Electronics, and Tuning' started by B18EG, Jul 22, 2003.

  1. B18EG

    B18EG Junior Member

    Likes Received:
    Jul 22, 2003
    I recently did a swap, putting a jdm b18c1 in my 1993 hatch (DX non-vtec). We finished the swap fast and easy. (we wired new wires from the ecu to the vtec pressure switch and the silonoid). When i drove it the first time and hit vtec, WOW the car flew. I loved it. After i punched the car about 3 times. The Check engine light turnd one. Also the car was now ideling at 2500 rpm. Now when i punched the car the rpm would rise slower and it would take a long time to hit vtec.

    HELP PLEASE !!!! :eek:
  2. seanjuan

    seanjuan Senior Member

    Likes Received:
    Jun 12, 2003
    Twin Cities, MN
    sounds like maybe the wires you ran came loose or got cut somehow. that is the first thing I would check. check the vtec plugs on the motor and where those wires tap into the ecu to make sure they are still makeing good conections. if that is fine then check that the wires you ran for vtec are not cut or shorting out somewhere.

    use a multimeter and check for continuity, or if you don't have a multimeter then just use a light bulb and a battery and try to conect the ground of the battery to the ground of the bulb using the wire that you put in. if it completes the circuit the light bulb will come on and you will know the wire is fine (make sure that the battery makes the light turn on in the first place though)

    if those tests check out then your problem is somewhere else and I would be able to help you

    good luck
Draft saved Draft deleted

Share This Page