1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Half shaft seal problem & Car pulls to right

Discussion in 'HYBRID -> ED-EF / DA' started by BMike, Sep 17, 2005.

  1. BMike

    BMike Junior Member

    Likes Received:
    Sep 17, 2005
    Thank you for taking the time to read my post. Any help you can offer would be much appreciated.

    I am trying to complete a B16 swap in a 1990 CRX Si. I was handed this project after it was 80% complete. Although I do have mechanical experinence, this is the first time I have worked on a CRX so I apologize if I have some of the termanology incorrect.

    I currently have two problems. First I have a fluid leak where the half shaft meets the transaxle. It is an S1 tranny and I believe the correct Interegra axles for the swap. What doesn't seem to make sense is the area in the tranny whre the seal sits is very deep compared the the area where the seal sits on the shaft. In addition, the transaxle has prongs that protrude outward and there is nothing between them and the seal...seems odd. It seems as if there is a piece missing between the prongs and the seal that would both hold the seal in the proper place and protect the seal from the prongs on the transaxle. I also seem too be having difficulty finding a the proper seal that fit properly on the ID and the OD.

    Second problem is that when it is assembled (and still leaking) the car pulls to the right and is hard to turn in that direction. Turns to the left fine. Could this be an improper axle situation? I have also read where the axle can be put in the wrong sides...could that be it? Since I inhereted this project almost fully assembled, I can't say it was done right in the first place.

    Please help!
Draft saved Draft deleted

Share This Page