1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

help needed

Discussion in 'Wheels / Suspension / Tires / Brakes' started by reckedracing, Feb 9, 2005.

  1. reckedracing

    reckedracing TTIWWOP VIP

    Messages:
    21,056
    Likes Received:
    1,180
    Joined:
    Dec 5, 2002
    Location:
    NY
    i'm at work right now, just went to get some lunch and my brakes are fucked, brake pedal is going to the floor, brake light comes on, limited stopping power...
    not loosing any brake fluid...

    master cylinder?

    pump the brakes with the truck off and the pedal holds, but as soon as i start it up i can pump, get pressure from the pedal, press and hold and it slowly drops...

    i know its the wrong forum, but i'm up shits creek and need help asap
     
  2. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    master or a leak in the booster prehaps?
     
  3. tylonalsnifnfool

    tylonalsnifnfool Senior Member

    Messages:
    983
    Likes Received:
    0
    Joined:
    Jun 12, 2003
    Location:
    ny
    check and see if fluid is leaking from the master cylander into the booster. If it just goes to the floor like you say then there has to be a leak in the system somwhere.
     
  4. StarBellieAngel

    StarBellieAngel Senior Member

    Messages:
    1,679
    Likes Received:
    0
    Joined:
    Jan 20, 2003
    Location:
    San Jose, CA
    check the SEALS. this is my issue i have in the teg... the brakes still work, they just suck ass, and worse when it's hot.
     
  5. reckedracing

    reckedracing TTIWWOP VIP

    Messages:
    21,056
    Likes Received:
    1,180
    Joined:
    Dec 5, 2002
    Location:
    NY
    thanks for the help guys (and gals)

    changed the master cylinder, brakes are mint

    had to nurse it home from work
     
  6. jdmracer

    jdmracer Member

    Messages:
    33
    Likes Received:
    0
    Joined:
    Jul 28, 2004
    its probably the piston seals in ur master cylinder
     
Verification:
Draft saved Draft deleted

Share This Page