1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Here's a mind boggle?

Discussion in 'Civic and del Sol - EG and EK' started by SCCAEK21, Jul 3, 2008.

  1. SCCAEK21

    SCCAEK21 New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Jul 3, 2008
    Location:
    TX
    I have a 99 honda civic CX hatch. I have: Ksport coilover's, Energy suspension master bushings, Front adjustable upper control arm's, Rear upper control arm's, And rear LCA's. My problem is it seem's like the passenger side is vibrating a little and it has a little howling. I just put new tire's and had an alignment, I also just changed the inner and outer tie rod's thinking it would fix the problem but it didnt. The only other thing I can think of is:

    The rack itself
    Hub bearing's
    lower ball joints

    Can anyone help?
     
  2. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    wheel bearing is what it sounds like
     
  3. SCCAEK21

    SCCAEK21 New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Jul 3, 2008
    Location:
    TX
    Thats kind of what I was thinking too. Here's another question. Are they press in?
     
  4. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
  5. SCCAEK21

    SCCAEK21 New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Jul 3, 2008
    Location:
    TX
    Hell yeah. If that doesnt fix the problem Im gonna give her a swift kick in the a$s..haha.
    No, if that doesnt fix it, what would be the next thing to look at?
     
  6. jesuslives

    jesuslives Banned

    Messages:
    65
    Likes Received:
    1
    Joined:
    Jul 24, 2008
    Location:
    in my garage
    dry axle check the boot
     
Verification:
Draft saved Draft deleted

Share This Page