1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Im Lost What Do I Do

Discussion in 'Wheels / Suspension / Tires / Brakes' started by flyguy, Apr 14, 2003.

  1. flyguy

    flyguy Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Apr 14, 2003
    hey guys whats up ....alright for starts i have a 91 crx with a b16a ...the car has eibach lowering springs in it for suspension work...so now my shock towers and everthing are just jammed in my wheel wells....can u guys tell me of a way to fix this with what i have or if u can tell me where i can get a full suspension kit, everything included for the actuall car.. also i dont have a front mount on the engine. do u know where i can get just the front mount. im more worried about the suspension cuz right now my axles are so tipped and angled it hurts inside to take turns.haha ..i need some advice...thanx guys.
     
  2. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    54
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    ummm what?

    your suspension is in your wheel well?

    you are driving without mounts, and you are worried about suspension?
     
  3. Civic_88ls

    Civic_88ls Senior Member

    Messages:
    267
    Likes Received:
    0
    Joined:
    Mar 6, 2003
    Location:
    everett, wasington
    Yeah, ummmm im not really sure what ur problem is>???

    and are ur axles boots still in one peice?? does it click?
     
  4. liquid00meth

    liquid00meth Senior Member

    Messages:
    3,201
    Likes Received:
    0
    Joined:
    Nov 26, 2002
    Location:
    Laconia, NH
    Well I would first worry about driving your car into a tree, and going for insurance fraud. I'm guessing there is so much permenant damage on the Ghetto-CRX that it's not worth trying to fix.
     
  5. Baker

    Baker Senior Member

    Messages:
    754
    Likes Received:
    0
    Joined:
    Oct 9, 2002
    Location:
    Schaumburg, IL
    you ever think that your axels are tipped because your engine isn't mounted in and is sagging? Get the mount first then take a look at the suspension, you probably damaged a lot of stuff by driving around without bolting your motor in. oh yeah STOP DRIVING YOUR CAR IF ITS BROKEN!!! especially until you get your motor in there right
     
  6. Slo86GT

    Slo86GT Super Moderator

    Messages:
    3,354
    Likes Received:
    0
    Joined:
    Sep 29, 2002
    Location:
    Memphis - Hellhole of the South
    You guys are a bunch of Fucktards. Seriously.

    The HasPort mount kit DOESN'T EVEN FUCKING USE the front mount. This guy probably has that, or a copy of that, and is driving the car without it. If the mounts are designed to work with only the three, then it doesn't need the front.

    As far as the suspension. This is where we need clarification. You need to get some decent springs, raise the car back up some, and get it drivable. That's the first and only option I would go with at this point.
     
Verification:
Draft saved Draft deleted

Share This Page