1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

introduction + i need some help

Discussion in 'Civic and CRX - EF' started by jdmkidef8, Jan 22, 2010.

  1. jdmkidef8

    jdmkidef8 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Dec 12, 2009
    hi everyone my name is kendall. im not new to hondaswap but i have never made a post or anything. once i made an account i forgot about it. but here i am so hi all. well let me tell you a little about the honda's i drive. my daily driver is a gold 1990 civic hatchback with the stock d15b2 dpfi motor nothing special just basic bolt ons. my second car i have is a project in the process of restoration i will make a build thread about it sometime but it is a white 1990 civic hatchback jdm dohc zc that i wanna build to turbo. here are some pics of both.
    her name is goldie
    [​IMG]
    and her name is whitey
    [​IMG]
    well thats my introduction now on to the problem with goldie my daily driver
    okay i am gonna try and make this as clear as possible but when i drive my car it is extremely sluggish under 3000 rpm but once it gets above 3000 rpm the power really kicks in, well not that it has lots of power but it drives like it should when its above 3000 rpm. last month my car broke down with a number of problems so here is a list of the parts that were replaced.
    new throttle body
    new injectors
    new distributor
    new throttle position sensor
    new o2 sensor
    new exhaust plus header
    new intake (ebay little pipe with filter you know :)
    new valve cover (old one was beat up)
    new spark plugs
    new spark plug wires
    new timing belt plus tensioner (old one was very worn)
    new fuel filter
    and last a fuel pressure gauge (the ones that connect on top of fuel filter)
    okay and thats it for the parts that i have gotten within the last month. the car starts up beautifully and is very consistent when it comes to start up. there is a slight bog when it is warming up but it has always done that. so the true question is what the hell is making my car do this limp mode under 3k it sucks when im casually driving to work.
    this problem is not model or engine bias it happens to tons of cars but from what i've seen no one has fixed the problem so i am hoping for everyone to chime in don't matter what car or motor you have any and all help is very much appreciated.
    thanks all at hondaswap
     
  2. SlushboxTeggy

    SlushboxTeggy It's only stupid if it doesn't work VIP

    Messages:
    9,392
    Likes Received:
    245
    Joined:
    Sep 14, 2004
    Location:
    New Jersey
    Very original with the names. Haha. And welcome to HS.

    I'm not really sure about you're problem though. Swapping in a B-series would probably take care of it....
     
  3. RoughKnight

    RoughKnight Christmas Car

    Messages:
    846
    Likes Received:
    25
    Joined:
    Aug 4, 2009
    Location:
    Ottawa, Ont
    her name is whitey lol
    nice
     
  4. jdmkidef8

    jdmkidef8 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Dec 12, 2009
    yeah they are very basic names haha but yeah i finally fixed the problem my distributor timing was not set or way off so i just had to advance it to match up with the total timing i think its called
     
  5. MexiChriS

    MexiChriS New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Nov 22, 2009
    Location:
    Lancaster, CA
    Sweeeeet, not bad! So have you done anything else to it since the fix or started working on towards your build thread!?
     
  6. dacheat

    dacheat ..is grounded.

    Messages:
    4,216
    Likes Received:
    205
    Joined:
    Jul 7, 2007
    Location:
    strongbadia
Verification:
Draft saved Draft deleted

Share This Page