1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Just need to confirm

Discussion in 'General Tech and Maintenance' started by xj0hnx, Apr 11, 2004.

  1. xj0hnx

    xj0hnx I wanna be sedated VIP

    Messages:
    14,172
    Likes Received:
    48
    Joined:
    Nov 10, 2002
    Location:
    C.C.TX.
    Brain not working right, and I am at work with no Helms.

    I drove on the autobahn, from my house to work a good 3.5 miles, autobahn hit 100mph, engine should be warmed up right, enough to open the thermostat? I got to work, and on a hunch due to the ever so faint smell of coolant, checked my bottom radiator hose, and it was cool (not cold, but like it was in an engine bay), the top was fairly warm, not uncomfortable to the hand though. Now I am suspecting my thermostat isn't opening, but I have no indication of overheating on the dash, and the car acts fine. Do you think I just didn't run it long enough, it was a fiftenn minute trip from my driveway to the parking lot on post.
     
  2. pills_PMD

    pills_PMD Super Moderator

    Messages:
    4,232
    Likes Received:
    0
    Joined:
    Sep 30, 2002
    Location:
    New Albany, OH
    probably just didn't run it long enough.. just keep a watchful eye on that temp gauge on the way home
     
  3. liquid00meth

    liquid00meth Senior Member

    Messages:
    3,201
    Likes Received:
    0
    Joined:
    Nov 26, 2002
    Location:
    Laconia, NH
    let it idle for 20 mins See if your fan comes on. Watch your coolant level.
     
  4. JDMilan

    JDMilan Senior Member

    Messages:
    6,730
    Likes Received:
    0
    Joined:
    May 11, 2003
    Location:
    Boca Raton, FL
    yeah, just observe it, let it idle for a little while and check the lower radiator hose.


    I wouldn't be that concerned, considering the thermo is cheap and easy to replace.



    but keep an eye on it.
     
Verification:
Draft saved Draft deleted

Share This Page