1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

maybe i can get an answer for my d16A6

Discussion in 'ECU's, Electronics, and Tuning' started by crxnonvtec, Aug 22, 2009.

  1. crxnonvtec

    crxnonvtec New Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    Jun 15, 2009
    I know this is for tuning..but most people viewing this know alot about the ecu...I have a d16a6 I cant get running its not throwing codes , I just cant figure out why the injectors wont fire more then once and it all 4 at the same time then nothing...the tdc sensor is good cause the distributor is brand new from top to bottom thought it was that...any help would be great
     
  2. 89' Project Civic

    89' Project Civic d16a6/d16y8 "mini-me"

    Messages:
    736
    Likes Received:
    6
    Joined:
    Mar 3, 2007
    Location:
    St. Catharines, Ontario, Canada
    Some parts come defective, try a different distributor. Also, is this a D16a6 in a Dx -or- Cx shell? Did you re-wire ANYTHING? If so, I had the same problem and it could be the two blank yellows at, I believe A5 and A7, are mixed up. Did you over tighten the fuel rail nut, and is your timing dead on?
     
  3. crxnonvtec

    crxnonvtec New Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    Jun 15, 2009
    yes I did a dpfi to mpfi swap and all the wiring related to the swap works properly and go to the proper pin outs on the ecu....that distributor better not be defective for 4oo bucks it a brand new not reman.. from the cap to the shaft...
     
  4. crxnonvtec

    crxnonvtec New Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    Jun 15, 2009
    yes I did a dpfi to mpfi swap and all the wiring related to the swap works properly and go to the proper pin outs on the ecu....that distributor better not be defective for 4oo bucks it a brand new not reman.. from the cap to the shaft...
     
  5. 89' Project Civic

    89' Project Civic d16a6/d16y8 "mini-me"

    Messages:
    736
    Likes Received:
    6
    Joined:
    Mar 3, 2007
    Location:
    St. Catharines, Ontario, Canada
    After closely reviewing your original post; I believe you may have crossed the two, thick and thin, white wires on the distributor wiring. These two wires look very similar and are crucial for the operation. It will not run what-so-ever if these two are crossed. Let me know how it goes. If that is not it we can troubleshoot furthur.
     
  6. crxnonvtec

    crxnonvtec New Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    Jun 15, 2009
    no I had both distributor plugs next to each other when they were swapped ...that would affect the spark not the fuel....its a fuel issue
     
  7. 78civic

    78civic Junior Member

    Messages:
    725
    Likes Received:
    10
    Joined:
    Oct 28, 2004
    Location:
    NW MS, Y'all
    Have the injectors been sitting with fuel in them..?
    You may need to pull them and wiggle the injector pintels with some carb cleaner or laquer thinner to clean them.
    I've had some engines that EVERYTHING was looking good but no start. Pulled, cleaned them and it fired right up.
    Just my .02

    E
     
  8. crxnonvtec

    crxnonvtec New Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    Jun 15, 2009
    they spray very strong and evenly but only one time
     
  9. 78civic

    78civic Junior Member

    Messages:
    725
    Likes Received:
    10
    Joined:
    Oct 28, 2004
    Location:
    NW MS, Y'all
    Going out on a limb.. Main relay?

    E
     
  10. 89' Project Civic

    89' Project Civic d16a6/d16y8 "mini-me"

    Messages:
    736
    Likes Received:
    6
    Joined:
    Mar 3, 2007
    Location:
    St. Catharines, Ontario, Canada
    Ah ha, I never thought about that, good diagnosis!
     
  11. 78civic

    78civic Junior Member

    Messages:
    725
    Likes Received:
    10
    Joined:
    Oct 28, 2004
    Location:
    NW MS, Y'all
    I've gotten used to just replacing them around here (Memphis area) on cars that I pick up because its soo hot when the cars just sit.
    I've seen dozens of them go out. And have several just in case in my box.
    And don't forget to pull the neg from the battery to clear the codes..

    Hope it works. E
     
  12. hooligan

    hooligan New Member

    Messages:
    69
    Likes Received:
    1
    Joined:
    Aug 24, 2009
    Location:
    ATL
    Make sure the injectors are getting constant 12 volts. If they are just a little off, like 11 volts they will not have enough to keep spraying. As far as I now 12 volts constant is the same for the D16A6.
     
  13. efhondakid

    efhondakid My name is Byron. VIP

    Messages:
    7,034
    Likes Received:
    202
    Joined:
    Mar 2, 2007
    Location:
    Akron-Canton, Ohio
    Injector wiring may be muffed up. Resistor box wired right?
     
  14. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    he says its all good but something obviously isnt right...where did you get the wiring schematic from?
     
  15. phunky.buddha

    phunky.buddha Admin with a big stick Admin VIP

    Messages:
    28,465
    Likes Received:
    228
    Joined:
    Sep 30, 2002
    Location:
    Dallas / Fort Worth, TX
    Have you tried a known good ECU yet? That's the first thing I check when there aren't any error codes...
     
  16. crxnonvtec

    crxnonvtec New Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    Jun 15, 2009
    the wiring to the resistor box is part of the stock si harness so i didnt have to run all the resistor box wires and the 4 injector wires go to the proper pin outs...as for the ecu I have 3 of them 2 from known running cars...I used a wiring chart someone sent me from rywire
     
  17. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    wait your running an si harness??
     
  18. crxnonvtec

    crxnonvtec New Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    Jun 15, 2009
    when will people learn to read?? its part of the stock si harness its just wires its so i could just plug into the resistor box
     
  19. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    nowhere in there did you specify what harness you used..
    so goodluck
     
  20. dacheat

    dacheat ..is grounded.

    Messages:
    4,216
    Likes Received:
    205
    Joined:
    Jul 7, 2007
    Location:
    strongbadia
    there's an ignition module in the distributor and if it's flaking out or done flaked out, that can be the cause as well.

    :shrug:
     
Verification:
Draft saved Draft deleted

Share This Page