1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Nasty Knock from Engine

Discussion in 'General Tech and Maintenance' started by RFHOMI2U, Nov 12, 2003.

  1. RFHOMI2U

    RFHOMI2U Senior Member

    Messages:
    301
    Likes Received:
    0
    Joined:
    Nov 28, 2002
    Loud ass knock coming from D16A6, doesn't do it when engine is cold for the first 20 minutes. Then it gets really loud. Engine starts really hard when it's cold. Seems like it runs on 3 cyl. cold for 15 min. I increased fuel on the AFC, and knock went away, but car started stalling and running like shit. Any suggestions on what could be wrong???

    oh yea.... getting code 3 and 6 (temp guage reads right, and code 3 is MAP sensor)
     
  2. MaliWho97

    MaliWho97 Senior Member

    Messages:
    568
    Likes Received:
    0
    Joined:
    Jan 16, 2003
    Well, I would guess its a rod or main bearing.
     
  3. brian11to1

    brian11to1 Senior Member

    Messages:
    9,203
    Likes Received:
    21
    Joined:
    Jan 9, 2003
  4. Paperchaser013

    Paperchaser013 Member

    Messages:
    43
    Likes Received:
    0
    Joined:
    Feb 26, 2003
    if it was a mechanical problem (such as bent rod or spun bearing), the noise would not go away with an increase of fuel on the afc.


    you might just have a bad tank of gas, fouled plugs or a messed up map sensor.
     
  5. RFHOMI2U

    RFHOMI2U Senior Member

    Messages:
    301
    Likes Received:
    0
    Joined:
    Nov 28, 2002
    I don't think theres a possibility of any of that stuff. Is there a possibility that an injector could be fouled? because if I increased the fuel, and it forced more fuel into the bad cylinder maybe that fixed the problem. But it started breaking up, maybe because the other injectors were putting in too much fuel. So you think it might be an injector?? I should check that...
     
  6. deth101

    deth101 Senior Member

    Messages:
    774
    Likes Received:
    0
    Joined:
    Mar 17, 2003
    Location:
    usa
    I'd at least check my filter...it can cause some goofy stuff
     
  7. liquid00meth

    liquid00meth Senior Member

    Messages:
    3,201
    Likes Received:
    0
    Joined:
    Nov 26, 2002
    Location:
    Laconia, NH
    check fuel things.

    retard timing a bit.
     
  8. Gen2Teg

    Gen2Teg Senior Member

    Messages:
    554
    Likes Received:
    0
    Joined:
    Jan 2, 2003
    Location:
    san francisco

    :werd: :withstupid:
     
Verification:
Draft saved Draft deleted

Share This Page