1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need help diagnosing

Discussion in 'General Tech and Maintenance' started by FLounder, May 11, 2010.

  1. FLounder

    FLounder power hungry VIP

    Messages:
    2,419
    Likes Received:
    137
    Joined:
    Jun 11, 2008
    Location:
    north palm beach, FL
    I have had a persistent problem with my car that is driving me nuts and Im looking for any advice. There was some conversation about it in my build thread, but Im still stumped.

    Background info.... the car was tuned on 7psi on Neptune and had no problems. When I changed pulleys and went to 10psi I have had this miss at 6500-7000 rpms. The engine stumbles at this exact same spot every time. Its barely noticeable in lower gears but on the dyno or a 3rd or 4th gear pull on the street you can feel it stumble. I got a new 3 bar map sensor, new cap, rotor, and plugs, and wires.... none of this helped. The distributor looks like new on the inside, connections are clean.

    Any ideas? I'd hate to buy a new distributor and thats not the problem either...
     
  2. Magana559

    Magana559 The Warden

    Messages:
    2,568
    Likes Received:
    42
    Joined:
    Aug 9, 2008
    Location:
    fresno Ca
    I had the exact same problem but my tac jumped like crazy.

    I took off all connections and cleaned them, then I put them back on and clamped them down with pliers. Turns out that the vibration kept shaking the connections lose. Now I dont have any Issue. Hope this helps.
     
Verification:
Draft saved Draft deleted

Share This Page