1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need help!

Discussion in 'General Tech and Maintenance' started by Lender69, Mar 18, 2005.

  1. Lender69

    Lender69 Senior Member

    Messages:
    347
    Likes Received:
    0
    Joined:
    Sep 12, 2003
    Location:
    New York City
    My engine is acting funny. When I turn on the car it starts to choke and then I smell gas? Does that mean my injectors are bad or my fuel pump? Can someone help me. Thanks :worthy:
     
  2. formby

    formby learning in progress

    Messages:
    5,735
    Likes Received:
    23
    Joined:
    Feb 19, 2003
    more info....engine? what did you do to it? what did you touch? any codes? be carefull and look for leaks...
     
  3. Lender69

    Lender69 Senior Member

    Messages:
    347
    Likes Received:
    0
    Joined:
    Sep 12, 2003
    Location:
    New York City
    This is what I have on my engine AEM Fuel Rail, B&G Regular, fuel gauge, AEM Cam Gears, Header, DC Sport front/back struts, No PR & AC, MSD spark plugs and JDM ECU. My p72 got messed up with I chipped it. So that is still being fixed. The engine by the way is a GSR. It was working fine but one day when I took it out to drive I heard a sound like two bolts fell inside a pipe. After that my car started choking and smell like gas. A few days after that my cousin when to check on it. When he turned on the car 2 cable caught on fire. He was able to turn it off before it got inside the car. He changed those wires but it is still making sound and smell. Any info you can give me will be useful and thanks again for your help. :worthy:
     
Verification:
Draft saved Draft deleted

Share This Page