1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Non vtec motor swapped in vtec car issue

Discussion in 'Civic - EP, FA, FG' started by friendshonda, Jan 3, 2013.

  1. friendshonda

    friendshonda New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Dec 30, 2012
    I don't own a Honda, think im in the right area. I'm a mechanic just doing the swap for a friends father. He has an 02 Civic with 1.7 vtec manual trans. Motor blew up. He could only find a non vtec motor in his price range. So he got the non vtec motor and PCM but the guy destroyed the harness removing it. So we used the old vtec harness on the non vtec motor and PCM. So car starts and runs fine but the check engine light comes on right away: PO141 O2 sensor #2 heater circuit. So my friend got a non vtec harness from someone else, installed it. The non vtec harness has 2 O2 sensor plugs at the front manifold. The manifold has only 1 upstream O2 and the rear stream O2 a lot farther down the exhaust. So only plugged one in. Still runs fine. Engine light comes on instantly again: PO141 still and now PO135-front O2 heater circuit now. Car will run and not change when I unplug the front O2. Now my question is: do I have the right harness? Or do I need the non vtec exhaust? I believe the rear O2 vtec harness goes through the dash harness and through the floor. Do I need the non vtec dash harness? Like I said I'm not a Honda expert but need advice on what will get the light to stay off. If even possible. Thanks for the help!
     

    Attached Files:

  2. 916em1

    916em1 New Member

    Messages:
    58
    Likes Received:
    0
    Joined:
    Sep 8, 2012
    From what i read the o2 sensors are actually different and that's what might be trowing the codes. Read this thread. http://honda-tech.com/showthread.php?t=2884386
    Good luck.
     
    Last edited: Jan 4, 2013
  3. friendshonda

    friendshonda New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Dec 30, 2012
    Thanks for the info. I posted on that thread
     
  4. damian86

    damian86 New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Jan 28, 2014
    if i where you id take the non vtec head off and re build it with the block with the vtec headit will save you loads of work
     
  5. SlushboxTeggy

    SlushboxTeggy It's only stupid if it doesn't work VIP

    Messages:
    9,392
    Likes Received:
    245
    Joined:
    Sep 14, 2004
    Location:
    New Jersey
    I hope he has the car running over a year later. That would suck...
     
Verification:
Draft saved Draft deleted

Share This Page