1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Now what happened to my d16z6?

Discussion in 'General Tech and Maintenance' started by Hexen, Sep 1, 2004.

  1. Hexen

    Hexen Senior Member

    Messages:
    715
    Likes Received:
    0
    Joined:
    Nov 14, 2002
    Location:
    Davis, CA.
    Okay here is the deal.

    I have a 94 Civic EX with ~165k miles.

    It runs great, haven't had any major problems ever.
    Just this last weekend I went to Kragen, when I came out the check engine light came on in the parking lot and the car died when I stoped.

    Started the car back up, no light. Car ran fine.

    Just now I went to Safeway to get a sandwich, no problems.
    I come out, car does NOTHING.

    I turn the key into aux and the lights will come on, door beep works, lights on the dash come on but stereo doesn't.

    Turn they key to start the motor, nothing. Absolutely nothing.

    Whats your thoughts?
     
  2. driverunknown

    driverunknown Senior Member

    Messages:
    1,474
    Likes Received:
    1
    Joined:
    Feb 11, 2004
    Does the car crank at all?
     
  3. Hexen

    Hexen Senior Member

    Messages:
    715
    Likes Received:
    0
    Joined:
    Nov 14, 2002
    Location:
    Davis, CA.
    No, no crank at all.

    If I pop it into Aux II all the dash lights come on bright, when I click over to start I hear a little popish clunk sound.

    If I go straight from Off to Start, it doesn't even do that, and the dash lights come on very dim.
     
  4. Hexen

    Hexen Senior Member

    Messages:
    715
    Likes Received:
    0
    Joined:
    Nov 14, 2002
    Location:
    Davis, CA.
    I've had the coil in the distributor go bad before.

    But if I remember correctly... it cranked but never turned over when that was the problem.
     
  5. Hexen

    Hexen Senior Member

    Messages:
    715
    Likes Received:
    0
    Joined:
    Nov 14, 2002
    Location:
    Davis, CA.
    Come on guys... someone give me hand here.

    I read up a bit on search and people have said it could be:

    PGMFI Relay
    Ignition Switch
    Distributor Ignitor
    Fuses

    Think?
     
  6. 94RedSiGal

    94RedSiGal Senior Member

    Messages:
    3,147
    Likes Received:
    1
    Joined:
    Sep 11, 2003
    Location:
    Massachusetts
    The check engine light went on, so pull a code on it?
     
  7. Hexen

    Hexen Senior Member

    Messages:
    715
    Likes Received:
    0
    Joined:
    Nov 14, 2002
    Location:
    Davis, CA.
    I'm going to see if I can't get the code when I go back over to Safeway where the car is. But I don't think most of those problems I listed throw specific codes.
     
  8. driverunknown

    driverunknown Senior Member

    Messages:
    1,474
    Likes Received:
    1
    Joined:
    Feb 11, 2004
    rule out the rmain relay. Is that the same as the pgmfi? If it is rule it out because the car will stilll crank with that out. It might even *gasp be your distributor.
     
  9. Hexen

    Hexen Senior Member

    Messages:
    715
    Likes Received:
    0
    Joined:
    Nov 14, 2002
    Location:
    Davis, CA.
    I thought the crank still cranked with the distributor, it just didnt fire?
     
  10. Hexen

    Hexen Senior Member

    Messages:
    715
    Likes Received:
    0
    Joined:
    Nov 14, 2002
    Location:
    Davis, CA.
    Anyone?

    I'm about to go back and check the ECU, maybe get it towed home.
    I hate having to use one of my AAA tows for like a 1 mile tow though.
     
  11. Hexen

    Hexen Senior Member

    Messages:
    715
    Likes Received:
    0
    Joined:
    Nov 14, 2002
    Location:
    Davis, CA.
    Simple solution to a stupid problem.

    There was corrosion on my positive battery terminal, I didn't even check before.

    Cleaned it off, got a jump, and it's charging again.
     
Verification:
Draft saved Draft deleted

Share This Page