1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

oil indicator lights up

Discussion in 'HYBRID -> ED-EF / DA' started by '89civicSI, Nov 26, 2004.

  1. '89civicSI

    '89civicSI Junior Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    Oct 3, 2002
    Got a new engine and it ran fine but a week later is tryed it agian. The head had a little more noize than usual. and a few minutes later also my check oil indicator lights up. This engine has an new oil filter and new oil. I suspect that the head isnt getting enough oil or something. What to do or check next.
     
  2. ryangt

    ryangt Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Sep 28, 2004
    did you put enough oil? did you let it warm a bit to see if it would go away? I always run a good engine cleaner through my engine about 3 days before i do an oil change just to make sure theres nothing clogged up in the passageways, try cleaning it out and changing the oil again, its probably your cheapest bet.
     
  3. reckedracing

    reckedracing TTIWWOP VIP

    Messages:
    21,056
    Likes Received:
    1,180
    Joined:
    Dec 5, 2002
    Location:
    NY


    wtf does that mean? or say???

    and check oil = low oil pressure
    could be a few things

    one, make sure oil didn't leak out from lets say a bad seal between block and filter
    2, not likely, but sometimes the valves inside the filter can be bad and not allow proper oil flow

    your oil pump could be bad, or the pickup tube could be clogged...

    or your presser sending unit isn;t working right

    but if you heard a lot of valve noiZe(wtf mate?) then i would say its probably starving for oil and NOT the sending unit..

    easiest thing to check is check the oil, and if its still full then change the filter, if that doesn't fix it then most likely you need to drop the oil pan and see what you can see....

    oh, and DO NOT RUN THE CAR WITHOUT PROPER OIL PRESSURE...
     
  4. '89civicSI

    '89civicSI Junior Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    Oct 3, 2002
    yes there is enough oil in it and i did first heat up the engine. i shall renew the oil.
     
  5. hcivic.com

    hcivic.com Senior Member

    Messages:
    4,571
    Likes Received:
    2
    Joined:
    Jan 7, 2003
    Location:
    Calgary Alberta canada
    what are you saying
     
  6. nfn15037

    nfn15037 Senior Member

    Messages:
    670
    Likes Received:
    0
    Joined:
    Mar 1, 2004
    FWIW, that oil light comes in with like ~4 PSI of pressure....not nearly enough to keep metal to metal contact from happening in the bottom end...DON't drive it or run it until you figure out the problem like everyone else has said!!
     
  7. '89civicSI

    '89civicSI Junior Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    Oct 3, 2002



    The engine didn't run for a week.
     
Verification:
Draft saved Draft deleted

Share This Page