1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Overheating problem

Discussion in 'Prelude' started by MJT805, Jun 18, 2009.

  1. MJT805

    MJT805 New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Jun 8, 2009
    I swapped in a jdm h22a to my 93 si. car runs great for the most part but after running for a while the temp. goes way high.

    I replaced the h2o pump along with timing and all that before i put the motor in and last night i put in a new thermostat and bled the system, still getting hot.

    Theres a 30-40% chance the h2o pump is bad or instaleld wrong but im pretty confident in my work. Any ideas on what i could do before taking the h20 pump out again?
     
  2. DESPAIN

    DESPAIN yep....mmhhm.......yep...

    Messages:
    1,703
    Likes Received:
    39
    Joined:
    Aug 1, 2008
    Location:
    flower mound TX
    take off the rad. cap and see if water is circulating?
     
  3. MJT805

    MJT805 New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Jun 8, 2009
    will i see the water moving thru ?
     
  4. pre92ludejs

    pre92ludejs New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Jun 13, 2009
    Location:
    Loveland, CO
    Do you see the coolant boiling in the reservoir or out of the Radiator cap?
     
  5. MJT805

    MJT805 New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Jun 8, 2009
    check back in like 3 hrs. everyone. im at work so i wont be able to get to it till im off. thanx
     
Verification:
Draft saved Draft deleted

Share This Page