1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

radio not working??

Discussion in 'Car Audio / Security / Electronic Accessories' started by efalex, Mar 26, 2010.

  1. efalex

    efalex New Member

    Messages:
    282
    Likes Received:
    3
    Joined:
    Sep 6, 2008
    Location:
    Danville NH
    got a stock si radio off my boy.. watched him putt it out.. it was working in his car when he took it out. i put it in my car, checked the fuse's and there all good, when i press the power button it doesnt work, but the anti theft light flashes and when i turn my lights on the radio lights up theres just no power.. weird
     
  2. ricksautomotive

    ricksautomotive honda dealer tech

    Messages:
    479
    Likes Received:
    11
    Joined:
    Mar 17, 2010
    Location:
    lancaster, ca
    sounds like you have a newer car (2000 and later to my imediate knowledge) which requires a radio code...is this true?
     
  3. efalex

    efalex New Member

    Messages:
    282
    Likes Received:
    3
    Joined:
    Sep 6, 2008
    Location:
    Danville NH
    yes it does, but the middle screen doesent even ask for the code... as if the middle screen doesnt get any power its weird
     
  4. ricksautomotive

    ricksautomotive honda dealer tech

    Messages:
    479
    Likes Received:
    11
    Joined:
    Mar 17, 2010
    Location:
    lancaster, ca
    chec any fuses on the rear of your new radio. then take your wire harness, twist the power and ignition wires together and connect them directly to your pos. batt. post. put the ground wire directly to your neg. batt. post. hook up your radio to the harness and see if it works. chances are it does but do this just to be sure you or your bay didnt accidently fry somethin
     
    1 person likes this.
  5. efalex

    efalex New Member

    Messages:
    282
    Likes Received:
    3
    Joined:
    Sep 6, 2008
    Location:
    Danville NH

    yea the idiot who had it b4 me cut the stockl plug off n re wired it shitty i pulled all the electrical tape off it n the main power wire wasnt connected lol so i re wired everything good taped it bak up and wat do u no it turns on... thanks guyy repp +
     
  6. yvette

    yvette New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    May 20, 2010
    need a code for radio
     
Verification:
Draft saved Draft deleted

Share This Page