1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

sunpro power curve tach trouble

Discussion in 'ECU's, Electronics, and Tuning' started by CRXratedR, May 3, 2008.

  1. CRXratedR

    CRXratedR Member

    Messages:
    52
    Likes Received:
    0
    Joined:
    Mar 9, 2004
    i installed an old Sunpro power curve LED tach (CP-8098) and it doesnt work. i ran other tachs with the same wires, like an Autometer 5 inch and another Sunpro II tach, and it worked fine. but when i tried to put this LED tach, all it does does is that the 1st LED will blink and nothing else. theres night light and stuff, its just that the RPM is not being read or something. wrong wire? but its the same tach signal wire i been using forever.. help anybody?
     
  2. nova TT

    nova TT New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    May 1, 2011
    Broken?

    Could the tach be bad? I've got a bit of experience with these and I'm thinking it may be broken. Email me if you still have it I'd like to buy it cause I need parts. mt_mechanic@hotmail.com
     
  3. bluejcivic

    bluejcivic New Member

    Messages:
    169
    Likes Received:
    0
    Joined:
    May 1, 2007
    maybe the ignitor went bad, happened to me before, the tach in my dash worked, but no aftermarket ones worked till i replaced it. good luck
     
  4. Matts96HB

    Matts96HB . Moderator VIP

    Messages:
    6,482
    Likes Received:
    389
    Joined:
    Apr 16, 2006
    guys, this thread is three years old.. lol
     
Verification:
Draft saved Draft deleted

Share This Page