1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

throttle body need help

Discussion in 'General Tech and Maintenance' started by dgie41, Jul 11, 2009.

  1. dgie41

    dgie41 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Jul 11, 2009
    My tps sensor needs replacing I did it once with an omni and had mixed results , I want to replace the whole throttle body with a stock one but can not find one anyone is selling except the dealer for $500.00,, forget that. Anyways I have a 1998 acura integra LS 1.8 liter dohc . What would be my best option try a blox tps or ?
     
  2. 99sidude

    99sidude Moderator Moderator VIP

    Messages:
    3,707
    Likes Received:
    170
    Joined:
    May 1, 2006
    Location:
    Ohio
    Did you just slap the new tps on there without calibrating it? You need to make sure the output is .5 volts at idle, and like 4.5 volts at WOT.
     
  3. dgie41

    dgie41 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Jul 11, 2009
    I tried to set it but the parameters are off when I try to set it
     
  4. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,413
    Likes Received:
    149
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    Loosing the bolts...have key to on position (motor off) plug into the ground and power (there's 3
    wires total...I think) with a multi-meter and calibrate at idle (engine off) at roughly .5v and tighten
    bolts up. See if that helps.
     
  5. dgie41

    dgie41 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Jul 11, 2009
    Already tried that, I am odering the blox tps and will try again. Having problems with the engine stalling at low throttle,fine at idle yet sometime idle is iratic also.
     
  6. awptickes

    awptickes unimpressed by you VIP

    Messages:
    9,271
    Likes Received:
    497
    Joined:
    Aug 29, 2007
    Location:
    MD
    what makes you think it's the throttle position sensor?

    What's your full setup? Head, block, intake manifold, ecu, etc.
     
  7. dgie41

    dgie41 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Jul 11, 2009
    All stock, problem seems to be dependent as to where the throttle is positioned, if I give it a little gas its trying to stall yet at the same time it will idle fine, when I give it more gas such as excellerating it seems to do fine. There seems to be a flat spot just above idle. Any suggestions other then tps, I am sure open for any.
     
  8. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,413
    Likes Received:
    149
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    He said the parameters were off so it isn't calibrated where it should be...which means....TPS needs to be adjusted
     
  9. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,413
    Likes Received:
    149
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    If it isn't calibrated correctly...how can you expect to find the correct diagnosis to the problem when you aren't fixing what you already changed? Fix TPS first and if problem still exists...then go from there.
     
  10. dgie41

    dgie41 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Jul 11, 2009
    Still waiting for blox tps to show up
     
  11. dgie41

    dgie41 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Jul 11, 2009
    Seems that the blox tps fixed it, it runs fine now,I need to ajust it a little more tomorrow.I screwed up and set it at .45 instead of .5,anyways thanks for the help everyone.
     
Verification:
Draft saved Draft deleted

Share This Page