1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

uncontrolible surging

Discussion in 'General Tech and Maintenance' started by 92dxhatch, Feb 20, 2007.

  1. 92dxhatch

    92dxhatch Senior Member

    Messages:
    955
    Likes Received:
    0
    Joined:
    Dec 15, 2004
    Location:
    nor*cal
    Hey guys,
    my civic is having issues again, its a d15b7, stock. but i'm having problems with it surging the revs, it goes from 1000 to 2500 and back to 1000 and so on, what do i need to do to correct this issue, its really annoying a low speeds. i am thinking maybe a sensor is out, but i'm cluesless as to what, maybe something to do witht the tps? anyways, could you give me a hand, thanks.
     
  2. turbo sol

    turbo sol I need some ligaments!!!

    Messages:
    791
    Likes Received:
    4
    Joined:
    Oct 6, 2006
    Location:
    laurel, montucky (ten minutes out of billings)
    replace the tps with a junkyard piece, if that doesn't work check the idle control valve.
     
  3. onesikdb8

    onesikdb8 Member

    Messages:
    63
    Likes Received:
    0
    Joined:
    Feb 24, 2006
    Location:
    AZ
    Check for vacuum leaks also
     
  4. phyregod

    phyregod !!YTINASNI

    Messages:
    9,449
    Likes Received:
    225
    Joined:
    Jun 11, 2005
    Location:
    Central Texas
  5. eg6sir

    eg6sir Supa Mod Moderator VIP

    Messages:
    21,703
    Likes Received:
    321
    Joined:
    Aug 17, 2005
    Location:
    661 BK CA
    my CRX did this.. it ended up being the idle screw on the TB
     
  6. joecivic

    joecivic save the single cams

    Messages:
    177
    Likes Received:
    2
    Joined:
    Sep 10, 2006
    Location:
    baltimore
    maybe your IAC valve
     
  7. 92dxhatch

    92dxhatch Senior Member

    Messages:
    955
    Likes Received:
    0
    Joined:
    Dec 15, 2004
    Location:
    nor*cal
    i tried looking for a vacuum leak but didn't see anything, and i tried the idle screw, doesn't do JACK!, im thinkin the tps, but could be the icv too, i'll talk a look, thanks.
     
  8. phyregod

    phyregod !!YTINASNI

    Messages:
    9,449
    Likes Received:
    225
    Joined:
    Jun 11, 2005
    Location:
    Central Texas
    Bleed your coolant? An air pocket in a honda would also cause that. And yeah, IACV/TPS/blah blah.. do the simple voltage checks on 'em.
     
  9. ThatGuy4life

    ThatGuy4life The Riced Sleeper

    Messages:
    1,478
    Likes Received:
    14
    Joined:
    Nov 27, 2006
    Location:
    Albuquerque, NM
    didn't know there was a voltage check for the IACV also
     
  10. YBLEGAL

    YBLEGAL Regular Member w/ Cheese

    Messages:
    2,762
    Likes Received:
    36
    Joined:
    Aug 9, 2006
    Location:
    NW Indiana
    they just oughta have a "my idle is fuck'd up" section.

    check ur coolent, bleed your coolent, clean your iacv, replace your iacv, check the voltage on the tps, replace the tps (usually not the tps b'cuz it'll throw it into limp home mode), check for vac leaks. now that i think of it, could be a bad map sensor as well. check which kind you have! there's the firewall mount version, or the tb mount version.

    ya, i recaped all responses. just felt it necessary. of course do all the things that dont require you to spend money, then go in the order of least cost here.

    in the future, there are much more lengthy tutorials online various places. google is your friend ^_^
     
  11. turbo sol

    turbo sol I need some ligaments!!!

    Messages:
    791
    Likes Received:
    4
    Joined:
    Oct 6, 2006
    Location:
    laurel, montucky (ten minutes out of billings)
Verification:
Draft saved Draft deleted

Share This Page