1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

VTEC broke?

Discussion in 'General Tech and Maintenance' started by psi, Dec 25, 2004.

  1. psi

    psi Junior Member

    Messages:
    54
    Likes Received:
    0
    Joined:
    May 5, 2003
    I got a problem with my b17 motor. The VTEC doesn't quiet kick in the way it should. I know on my civic hybrid swap it works flawlessly. But on my GS-R it kicks in between 6500 to 7000 RPMs. I know that isn't right. So, what do you all out there think the problem is?

    psi
     
  2. K2e2vin

    K2e2vin Senior Member

    Messages:
    8,446
    Likes Received:
    92
    Joined:
    Jan 2, 2003
    Location:
    Raleigh, NC
    it probally has the vtec set up so its most efficient (no spikes or jump in torque in the powerband)
     
  3. B16RacerN2NR

    B16RacerN2NR Working Hard VIP

    Messages:
    6,148
    Likes Received:
    99
    Joined:
    Feb 28, 2003
    Location:
    Moving back West...

    ecu might need a little programming
     
  4. nfn15037

    nfn15037 Senior Member

    Messages:
    670
    Likes Received:
    0
    Joined:
    Mar 1, 2004
    Well the P61 ECU should have VTEC set around 5800 or so. Check the oil level and check the VTEC solenoid screen.
     
  5. cycloneb18c3

    cycloneb18c3 Senior Member

    Messages:
    1,056
    Likes Received:
    0
    Joined:
    Aug 10, 2003
    Location:
    New Jersey
    my buddy had a chipped ecu, for his ITR engine in a EG hatch, and the vtec kicked at 6500, and it pulled like a mo fo all the way to redline.....
     
  6. psi

    psi Junior Member

    Messages:
    54
    Likes Received:
    0
    Joined:
    May 5, 2003


    So, it could be a problem with the oil pressure or the solenoid? I'll look into that. Thanks. The GS-R's VTEC's been like that since I bought the car.
    Thanks.
     
  7. Bl6CRX

    Bl6CRX Senior Member

    Messages:
    1,553
    Likes Received:
    0
    Joined:
    Jul 14, 2003
    Location:
    UCLA
    yeah it sounds like an oil pressure problem to me
     
  8. formby

    formby learning in progress

    Messages:
    5,735
    Likes Received:
    23
    Joined:
    Feb 19, 2003
    yeah it could be
     
  9. arroshiz

    arroshiz Senior Member

    Messages:
    244
    Likes Received:
    0
    Joined:
    Aug 22, 2004
    i've got a b17 too and supposedly its supposed to kick in at 5600 but mine kicks in at around 6...i got the same prob
     
  10. psi

    psi Junior Member

    Messages:
    54
    Likes Received:
    0
    Joined:
    May 5, 2003
    Have you tried to tweek when the VTEC kicks in or has it been that way since you got it? I can really hear the difference between my b17 and my b16. The b16 in my civic has that distinctive sound when VTEC kicks in. On my b17, it kicks in really late and sounds like its trying to switch to VTEC but can't.

    Is this a common prob with the b17s?

     
  11. dohch22a4

    dohch22a4 Senior Member

    Messages:
    1,744
    Likes Received:
    0
    Joined:
    Feb 5, 2003
    Location:
    Spokane, WA
    It shouldn't be. Make sure your screen on the VTEC solenoid is clear of any buildup and make sure your oil isn't low.
     
Verification:
Draft saved Draft deleted

Share This Page