1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Vtec pressure switch problem

Discussion in 'HYBRID -> EG-EK / DC' started by totally insane, Jul 4, 2008.

  1. totally insane

    totally insane Junior Member

    Messages:
    20
    Likes Received:
    0
    Joined:
    Jul 7, 2006
    i am getting code 22.my car does not vtech when it gets warm. Currently its not at all.Change the pressure wich and the ecu its still the same.It only vtecs with my hondata but feels pretty weak.Ialso tried bypassing the switch but once the car got warm it was back again and if i turn off the car and put it back on i get no codes until i go back into vtech.
     
  2. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    your car has to be warm to hit vtec and also check to make sure your car has enough oil
     
  3. totally insane

    totally insane Junior Member

    Messages:
    20
    Likes Received:
    0
    Joined:
    Jul 7, 2006
    yes oil is good and i also know it should be warm to activate. the thing is it vtecs when the temp gets over the first mark.but once its at half it stops.i checked the grown connections but dont know what to check next.
     
  4. pooksy64

    pooksy64 RidetilldeathdousparT

    Messages:
    148
    Likes Received:
    1
    Joined:
    Jul 18, 2008
    Location:
    HOUSTON tX
    ohm out the pressure switch, check for specs. in closed oper, comp looks for a knock sig, oil psi sig, and map sig.
     
Verification:
Draft saved Draft deleted

Share This Page