1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

vtec problem...

Discussion in 'HYBRID -> EG-EK / DC' started by hybridracer504, Nov 18, 2003.

  1. hybridracer504

    hybridracer504 Senior Member

    Messages:
    107
    Likes Received:
    0
    Joined:
    Sep 5, 2003
    i need a lil help....well here's how it went...i juss finished droppin in the motor and juss got it running....well on the first day u really drive it hard....and on the second day...i did...well i was goin about 40 mph and downshifted to 2 and as soon as vtec was about to kick in the check engine light came on so i got back home and pulled up sum codes....there where 2 codes....21 and 23...can sumone please help me out...thanks
     
  2. civic15.8

    civic15.8 Senior Member

    Messages:
    521
    Likes Received:
    0
    Joined:
    Feb 17, 2003
    Location:
    alabama
    im guessing you want to know what the codes stand for?
     
  3. civic15.8

    civic15.8 Senior Member

    Messages:
    521
    Likes Received:
    0
    Joined:
    Feb 17, 2003
    Location:
    alabama
  4. B16aJWHO

    B16aJWHO Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Nov 12, 2003
    I also get a code 21, but I checked my vtec solenoid and it is still in working condition. Is there anything else that would cause this code to come up? maybe a bad ecu?
     
  5. hybridracer504

    hybridracer504 Senior Member

    Messages:
    107
    Likes Received:
    0
    Joined:
    Sep 5, 2003
    yea...ive checked dat also...and it is workin properly but ive got to check the knock sensor again cuz i havent checked dat yet..and how can i fix dat problem...thanks
     
  6. darwins_vtech

    darwins_vtech Senior Member

    Messages:
    250
    Likes Received:
    0
    Joined:
    Jun 4, 2003
    Location:
    Wisconsin
    the car isn't wired for a knock sensor, if it is a OBD1. you have to run a wire from the sensor to the ECU so that it will register, unless you are using an ECU that isn't looking for it. the knock sensor is a single wire plug/bolt that is located on the back of the block, below the intake manifold and by the oil filter. I think it is a green wire most of the time. just run a wire from that sensor along the wire loom to the ecu and Plug it in spot D3 or 4. Not sure. THere shouldn't be a wire in the place though- it should be an empty spot on the ecu harness.

    DArin
     
  7. civic15.8

    civic15.8 Senior Member

    Messages:
    521
    Likes Received:
    0
    Joined:
    Feb 17, 2003
    Location:
    alabama
  8. hybridracer504

    hybridracer504 Senior Member

    Messages:
    107
    Likes Received:
    0
    Joined:
    Sep 5, 2003
    well...ive checked it and the wire is not green...it is yellow and red...so do i juss do the same procedure dat u told me...thanks
     
  9. Bl6CRX

    Bl6CRX Senior Member

    Messages:
    1,553
    Likes Received:
    0
    Joined:
    Jul 14, 2003
    Location:
    UCLA

    right
     
Verification:
Draft saved Draft deleted

Share This Page