1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Will P06 work with D16Z6?

Discussion in 'General Tech and Maintenance' started by b_ricker, Oct 11, 2005.

  1. b_ricker

    b_ricker Junior Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Sep 28, 2005
    I have searched all over for this information. What is the major difference other than that the P06 has no vtec wired into it. Is the timing different? The reason I ask is because I dropped a D16Z6 in a 94 DX and engine turns but will not start. Any suggestions would be helpful. Thanks.
     
  2. b_ricker

    b_ricker Junior Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Sep 28, 2005
    More importantly will it even start.... I am trying to isolate the problem and if it is the ECU it will save me lots of time.
     
  3. kyleirwin

    kyleirwin Retired OG

    Messages:
    2,420
    Likes Received:
    2
    Joined:
    Oct 24, 2002
    Location:
    Vegas
    yeah, it'll work. you just won't have vtec like you said. the two engines aren't too different. it won't run as well as it would with a p28... but it will run it well enough to get around until you get a better ecu.
     
  4. b_ricker

    b_ricker Junior Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Sep 28, 2005
    Do you have any suggestions then as to why it is almost starting then immediatly stops? Almost like a sputter then it dies because I have double checked all my connections. Any help would be great. thanks.
     
  5. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    ummmm...wrong fuel maps?
     
  6. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
  7. kyleirwin

    kyleirwin Retired OG

    Messages:
    2,420
    Likes Received:
    2
    Joined:
    Oct 24, 2002
    Location:
    Vegas
    i've run a b16 on a p06, and it ran fine. a p06 will run a z6 fine. either your ecu is shit... or something else is wrong.
     
  8. b_ricker

    b_ricker Junior Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Sep 28, 2005
    Wow so I found out what it was, I ordered the distributor from a place used and when they took it out they dropped it and broke the the part that sticks out of the ignition coil... then glued it back on. Luckily there was an ignition coil in the other one... changed it out and the engine fired right up. I appreciate all those who were able to help out.
     
Verification:
Draft saved Draft deleted

Share This Page