1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wiring A 94 Ls Ecu To A 93 Civic Cx

Discussion in 'ECU's, Electronics, and Tuning' started by visiontcivic, Mar 24, 2003.

  1. visiontcivic

    visiontcivic Member

    Messages:
    36
    Likes Received:
    0
    Joined:
    Sep 30, 2002
    When i was connecting the harness to the ECU my CX harness has only 3 plugs, and it looks like the LS ecu has four slots for the plugs... whats that third one and do I need it? Plus how do I hookup the O2 senor, My stock one has like a 1 wires i think and the ls has like 4 wires.. Need help soon thanks
     
  2. pills_PMD

    pills_PMD Super Moderator

    Messages:
    4,232
    Likes Received:
    0
    Joined:
    Sep 30, 2002
    Location:
    New Albany, OH
    what is the code on the LS ecu?
     
  3. vtecsir1

    vtecsir1 Senior Member

    Messages:
    3,313
    Likes Received:
    17
    Joined:
    Dec 5, 2002
    Location:
    Orlando, FL
    you need a 4 wire o2 sensor
     
  4. AllMotorMonster

    AllMotorMonster Senior Member

    Messages:
    542
    Likes Received:
    0
    Joined:
    Oct 13, 2002
    Location:
    Inland Empire foo!

    If the LS ecu has 4 slots for plugs, you got yourself a OBD2 ecu.

    You need a 92-95 OBD1 LS ecu.

    OH, and yea, add 3 wires for the 02 sensor like vtecsir said.
     
  5. visiontcivic

    visiontcivic Member

    Messages:
    36
    Likes Received:
    0
    Joined:
    Sep 30, 2002
    how do i hook up the 3 wires, and can i use the ecu thats obd2 on a obd 1 engine? and not use that 4th plug
     
  6. AllMotorMonster

    AllMotorMonster Senior Member

    Messages:
    542
    Likes Received:
    0
    Joined:
    Oct 13, 2002
    Location:
    Inland Empire foo!

    Buy a Helms manual and check the pinouts

    And

    Negative on the OBD2 ecu on a OBD1 engine.


    Buy a OBD1 P74/75

    OR

    Buy a P06 and have it chipped to P74/75 specs
     
  7. nism

    nism Junior Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Apr 7, 2003
    i have P75 OBD1 ecu on my 94 ls, and it has 4 plugs(it is rare, but it does exist)
     
  8. visiontcivic

    visiontcivic Member

    Messages:
    36
    Likes Received:
    0
    Joined:
    Sep 30, 2002
    Yeah I think thats what i got, becuase mine has 4 plugs, and i didn't use the 4th one, and it still works fine... i just need to know how to hook up the O2 sensor, and the map sensor, now im drving around with the CEL but other than that its working good.
     
  9. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home

    WTF?

    take a pic of this rare ecu
     
  10. -nismo-

    -nismo- Junior Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jun 16, 2003
    do not have a picture of it right now,but I know for sure it is from 1994 jdm integra,and the stiker says it is p75, auto ecu ,and the third plug is for auto tranny wiring.And recently,I did ls/vtec swap,and I replaced this p75 with pr3-j00,and now I got cel ,and the car is idling around 2000 all the time,cant solve the problem,any ideas?

    And people,sorry for my english
     
  11. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    what code are you getting? consult the articles section on page 4 for more info on pulling the codes.
     
Verification:
Draft saved Draft deleted

Share This Page