1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

won't go over 4500 after ecu swap

Discussion in 'HYBRID -> EG-EK / DC' started by texasborn81, Sep 30, 2010.

  1. texasborn81

    texasborn81 New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Sep 28, 2010
    couple of things...swapped d16z6 into 93 dx 4dr, used dx harnesses. just bought a p28 for auto. wired vtec according to what i've seen online. went for a test drive and car was running rough would not go over 4500 (sputters bad) unplugged connectors for vtec and it runs fine. i guess i have to go back check wiring.
    if this helps---car is 5spd p28 is auto, just wanted to amke sure it worked before opening it up to convert to 5spd...i bought at a pick and pull and it has warranty!
     
  2. haao13

    haao13 New Member

    Messages:
    529
    Likes Received:
    6
    Joined:
    Aug 19, 2007
    Location:
    PA
    it wont go over 4500 cause the ecu is for an automatic
     
  3. K2e2vin

    K2e2vin Senior Member

    Messages:
    8,446
    Likes Received:
    92
    Joined:
    Jan 2, 2003
    Location:
    Raleigh, NC
    That wouldn't cause it to not go over 4500rpm; it would just throw a code for the solenoids.

    Is the ECU chipped or something? Also check continuity for VTEC to make sure it's not engaging under the pre-set RPM(pretty much should not be on during idle).
     
  4. tabKola

    tabKola New Member

    Messages:
    326
    Likes Received:
    5
    Joined:
    Jul 3, 2008
    Location:
    Tewksbury MA
    Is it throwing any codes besides the ones for the missing auto tranny?
     
Verification:
Draft saved Draft deleted

Share This Page