We may earn a small commission from affiliate links and paid advertisements. Terms


New Member
Ok im new to the forums, but not to new to the honda scene. Today i purchased a 96 Accord with a " Swap " done to it. Earlier tonight I looked @ the block and it has f22B1 stamped on it, The thing is its a DOHC vtec head on the motor. Google has told me that the f22B1 was a sohc engine. The problem that I am having is that when driving the car whenever you hit 4k rpm's the car rev bounces its looking for vtec and cannot find it. Im unsure of what ECU that i need to run in the accord. Its a automatic transmission. Someone please help me or point me in the right direction. If anyone has the ecu needed to make this work please message me and let me know what you're asking for it

Sounds like the car is in limp mode, which results from certain CELs being on. Is the CEL on? I'm guessing it's an H22 head, so you'll probably want an auto H22 ECU...
you would be referring to thte check engine light ? If so no light on @ all. car runs smooth just cant engage vtec PERIOD. Only lights on on dash aare the brake light b/c the ABS.
Sorry for the omment being taken the wrong way man. Ok so its not a dohc its a f22b1 swap, im not sure what ecu to run aint sure if its odb1 or 2 either. Today the check engine ligh came on finally and it wont go past 4500 rpm. bounces like a rev limiter.
Well, the chassis is OBD2, but without actually being able to look at the car and the ECU it's going to be hard to figure out what's going on. Either they put the OBD2 accessories on to the older motor and are trying to run it as OBD2, or they tried to convert it to OBD1 (in which case it's an OBD1 ECU).

Have you tried pulling the error code yet? Sometimes the obvious things are the last thing we think to check. I mean, it could just be an unplugged O2 sensor or something like that. That's enough to cause the car to go in to "limp mode", and I'm like 99% sure that's what's happening to you. My 97 Integra did this when the after-cat O2 sensor wasn't plugged in. It limits your revs to around 4k, the idea being that you have to baby the car around until the problem is resolved so that no damage is caused to the engine.

Get the code read ASAP. That will at least give us something to go off of. Also, a detailed visual inspection of the engine and engine bay can't hurt. If it is a case of something simply being unplugged, then that's an easy fix. If it's because of a hack-job install or hack-job OBD conversion though, then that will be a bigger issue...
Last edited:
Ok Update. The Car is Definatley a obd2 ECU.
Today i finally got a cel and the code reader said it was insufficent egr flow. I also noticed that the vtec solenoid is not hooked to anything, just sitting there harness and nothing hooked to it.
the ecu in the car is the sohc non-vtec ecu. Among that i had a terrible vaccum leak due to a valve cover bolt and groumet missing. Got the bolt and groumet from the local honda dealer. The motor swap was performed by Augusta Customs and was installed correctly. So now the question I pose is this.

Is there a way the obd2 ecu for non vtec run the vtec in the car if the vtec is hooked to ecu somehow ? And if not can anyone please tell me the correct ecu to run in the car ? Im just wanting to get the car able to kick vtec in its annoying to not be able to drive the car over 4k, its also starting to rev up then drop down, and repeat spikes about 1500 rpm's and then drops to around 500 rpm's. Only does this when the car is at idle and doesnt always do this. Any suggestions ?????

Probably easiest just to try and find an OBD2 F22B1 ECU. OBD1 ECUs are much easier to reprogram, but OBD2 is trickier. And I would try cleaning out the EGR valve to see if that will fix the CEL. I'd clean out the EGR valve and then reset the ECU (unplug the battery and let it sit for a few minutes, then hook the battery back up, turn the car on and let it idle). The idle problems may be due to the clogged EGR, and I'm sure that the car's in limp mode, that's why you can't rev past 4k. That issue should go away once the CEL is resolved...
Found the vtec solenoid and pressure switch today they are NOT even hooked up the guy that did the swap said it was because he didnt have the ecu and didnt wanna damage the engine. so i can get a 97 accord ex vtec ecu and it should work correct? im sure the wire not being hooked to any pin is the culprit of no revs over like 4k
in obd2 cars if you don't have a vtec ecu running in the car it will casue it to stop at the vtec kick in point.. I had a simmular problem I had a 99 civic ex with a d16y7 non-vtec motor and had a vtec ecu and it cut out at 4800...
Ok so does anyone have a idea what car to find a ecu from since the cars a auto tranny, its a 97 motor i know that

If it's a 97 F22B1, then you need an OBD2a F22B1 ECU, and I'm fairly certain that the code for that ECU is 37820-P0H-L51.

The "POH" designates that it's the OBD2 version, and the "L51" designates that it's for an automatic. If you see one that says "L52", that's for a manual. And if it's "POA" instead of "POH", that means it's the 94-95 OBD1 version...
just went and got the ecu plate off and this is what i got

this is the number on the ecu as follows:


ecu has long harness connected to back
watz up guys i was wondering if a f22b1 tranny would it fit in a f20b engine? please let me know thanks....
watz up guys i was wondering if a f22b1 tranny would it fit in a f20b engine? please let me know thanks....

Yes, but next time please start your own thread as opposed to butting in on someone else's...
Radiator fan not coming on

I connected it to battery and turned on. So fan is good. I jumped thermostat switch and only a/c fan came on. Car heats up 3/4 of way on gauge. Need help.