1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A Few Simple DOHC ZC Q's

Discussion in 'HYBRID -> ED-EF / DA' started by jcl8706, Aug 27, 2007.

  1. jcl8706

    jcl8706 New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Jul 23, 2007
    I recently bought an 89 hatch w the blacktop dohc zc swap and the wiring to the ecu and sensors is hacked. Is there a good link or reference anyone has to what the correct wiring for the swap would be?
    The car has a PM6 ecu, would it benefit it alot to get a PM7 ecu?
    The O2 sensor has the insulated signal wire with wire wrapped around the insulation, anyone know which goes where?
    Ive done alot of research and its supposed to be a decently quick car with the swap, but this thing has no balls under like 4500..timing marks are dead on..any suggestions?
    Help=good! Thanks
     
  2. spinninhonda

    spinninhonda New Member

    Messages:
    33
    Likes Received:
    0
    Joined:
    Apr 30, 2007
    first off d-series.org for the wiring, and yes a pm7 helps alot, or just have the pm6 chipped with a pm7 basemap and get a tune, i put a friends form 15.5 to 14.8 on just a tune with an intake header and exhaust
     
  3. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs
    what model is the car? DX or Si? wiring varies with model - PG7 ECU from 88-89 Integra will also work about the same as the PM7 - both have higher rev limiter than the PM6 - doe it have Check Engine Light and codes? are you sure that camshaft timing is correct? do you know what transmission it has?
     
  4. jcl8706

    jcl8706 New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Jul 23, 2007
    Its an Si, the CEL comes on and stays on after it runs for a little while, I already retimed it and its dead on. Throwin codes 17, 1, and 20.
    The trans was a DX, but I swapped out the ring gear and pinion shaft to the SI 4.25 gears because I had to replace a bad shift fork.
     
  5. jcl8706

    jcl8706 New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Jul 23, 2007
    Well I got the usdm 89 teggy ecu.. it helped, but still throwin codes.. Some of the wire colors on the plugs dont match what ive looked up in the chiltons or haynes, or the online forums, a few are cut off the plugs that dont match, and a few are cut off the harness that are hanging that dont match..
     
  6. 1988hondacrxsiR1

    1988hondacrxsiR1 Banned

    Messages:
    230
    Likes Received:
    0
    Joined:
    Sep 10, 2007
    Location:
    Midwest
    What Are The Codes? On The Integra Ecu.;)
     
  7. 1988hondacrxsiR1

    1988hondacrxsiR1 Banned

    Messages:
    230
    Likes Received:
    0
    Joined:
    Sep 10, 2007
    Location:
    Midwest
    THE PM6 SHOULD WORK FINE. WhAT WERE THE CODES ON THAT BEFORE?;)
     
  8. jcl8706

    jcl8706 New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Jul 23, 2007
    Its throwin 1 (o2 sensor), 9 (cyl 1 position), and 20 (electronic load). Timing is balls on, used the timing writeup from zcspeed.com. Is the electronic load pos in the fusebox under the hood or under the steering wheel? Im going to buy a generic 1wire 02 and see if that goes away, and will try switching the wires on the cyl position sensor to see if that fixes it. My wiring's hacked at the ecu, butt connectors and a couple wires hanging, few wires that dont exist on the schematic lol..
     
  9. 1988hondacrxsiR1

    1988hondacrxsiR1 Banned

    Messages:
    230
    Likes Received:
    0
    Joined:
    Sep 10, 2007
    Location:
    Midwest
    BUy a manual and follow color wire and code #20 does not exist in my data. GOOD LUCK!:cool:
     
  10. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs
    the ELD is in the underhood fuse box - not replaceable without replacing the entire fuse box - if the car is a Canadian model, i don't believe it has ELD
     

    Attached Files:

    Last edited: Sep 12, 2007
  11. 1988hondacrxsiR1

    1988hondacrxsiR1 Banned

    Messages:
    230
    Likes Received:
    0
    Joined:
    Sep 10, 2007
    Location:
    Midwest
  12. jcl8706

    jcl8706 New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Jul 23, 2007
    Well regardless, its throwing a code 20. I bought another o2 sensor..didnt fix it. Switched the wires on the cyl pos sensor..didnt fix that either. These sensors are zc only, not teggy correct?
     
  13. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs
    88-89 Integra Cylinder sensor is the same as the DOHC ZC
     
  14. 1988hondacrxsiR1

    1988hondacrxsiR1 Banned

    Messages:
    230
    Likes Received:
    0
    Joined:
    Sep 10, 2007
    Location:
    Midwest
    all o2 sensors are the same for ef and ed and da
    all that ef ek all are different minus emission cars they are bigger;)
     
  15. jcl8706

    jcl8706 New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Jul 23, 2007
    Ya i meant to ask if *the cylinder pos sensor is zc only*..but thanks, i might have to go get one
     
  16. blackice90HB

    blackice90HB Senior Member

    Messages:
    357
    Likes Received:
    0
    Joined:
    May 16, 2005
    Location:
    Pensacola, Florida
    I got one 35 shipped. 88-89 tegs with the D16A1 motor have tose CPS, just like your DOHC and the D16a8/9. other D-series are single cam and dont have them, they are in the distributor. Easy fix is to run a Si dizzy, but you will have to re pin it and only one bolt lines up. I have a re-pinned Si dizzy to for 60 shipped. With the Si dizzy you dont need to have the CPS plugged up, just bolted in to keep it from leaking oil
     
  17. jcl8706

    jcl8706 New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Jul 23, 2007
    Well I got the 02 problem fixed, the wire going into the harness was repinned to a different socket...i dont understand why the chickenfooker before got everything a$$-backwards.. cyl sensor is correctly pinned with no shorts to ground..going to recheck timing this weekend otherwise goin to get a know good sensor! The wire going to the ELD is just hanging, and cant figure out where its supposed to be pinned so whatever i guess haha
     
  18. 1988hondacrxsiR1

    1988hondacrxsiR1 Banned

    Messages:
    230
    Likes Received:
    0
    Joined:
    Sep 10, 2007
    Location:
    Midwest
  19. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    you are perma banned.
     
  20. jcl8706

    jcl8706 New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Jul 23, 2007
Verification:
Draft saved Draft deleted

Share This Page