1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Advice on running problem with 88 S10

Discussion in 'Other Vehicle Discussions' started by Jdubspeeds, May 24, 2004.

  1. Jdubspeeds

    Jdubspeeds Senior Member

    Messages:
    503
    Likes Received:
    0
    Joined:
    Jun 9, 2003
    Location:
    Tacoma Wa
    When its cold it runs perfect, when its warm it doesnt want to start. It cranks, has spark, It appears to have fuel. This is a TBI model. I just put new spark plugs and fuel injection cleaner to see if I was fouling my plugs. When I took them out they appeared black with soot. Anything else I should be looking for? I was thinking maybe its the fuel pump? When it doesnt start when its acting up like this if I floor it, it will barely run. Then after doing that for a bit I can rev it up fine in nuetral. When I drive it underload it spits and sputters and doesnt wanna run right.
     
  2. brian11to1

    brian11to1 Senior Member

    Messages:
    9,203
    Likes Received:
    21
    Joined:
    Jan 9, 2003
    fuel filters/pump?
     
  3. tlb1127

    tlb1127 Banned

    Messages:
    47
    Likes Received:
    0
    Joined:
    Apr 21, 2004
    88 S10 Truck?????????? Confused if your asking about a truck or honda???
     
  4. BigJ

    BigJ I'm just about that action Boss. VIP

    Messages:
    11,090
    Likes Received:
    408
    Joined:
    Oct 4, 2002
    Location:
    Washington
    Weird....

    What motor's in it? The 2.2l 4banger, 2.8v6, or the 4.3l v6?
     
  5. driverunknown

    driverunknown Senior Member

    Messages:
    1,474
    Likes Received:
    1
    Joined:
    Feb 11, 2004
    o2 sensor?
    Timing?
    I don't know man bump!!!!
     
  6. turboB20hatch

    turboB20hatch Senior Member

    Messages:
    355
    Likes Received:
    0
    Joined:
    Apr 2, 2004
    Location:
    pacific nw
    2.2L 4 banger... and yes its a s10 TRucK

    as long as u sell it while the motors cold it should be fine.
     
  7. asmallsol

    asmallsol Super Moderator

    Messages:
    8,074
    Likes Received:
    3
    Joined:
    Sep 28, 2002
    Location:
    Houghton/Livonia Michigan
    wrong section, non honda tech goes into Other vechiles
     
  8. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    does it have a MAF? thats a typical problem of a dirty maf
     
Verification:
Draft saved Draft deleted

Share This Page