1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B16a Engine Problems( injectors,codes)

Discussion in 'ECU's, Electronics, and Tuning' started by clutchn, Jun 8, 2011.

  1. clutchn

    clutchn New Member

    Likes Received:
    Jun 8, 2011
    Okay so i just recently pulled the motor out of my del sol like two days ago to swap a trans. and everything ran fine before including injectors and everything else, was not throwing any codes what so ever.... now i put the motor back in today and hooked everything up the way it was before, except now its throwing codes 6 10 16 36 thats what the cel is reading in the dash... So i know 16 is the fuel injector system and when i had the car running, one by one i killed the fuel to the cylinders and one by one they did die, except for number 4... that one when i unplug the injector clip it does not change anything so i assume the car is now running on 3 cylinders which i think is why the car is now in limp mode... i checked the wires from where i could reach on the harness and they are all conected and not grounded out. Could it be the ecu? i have a p28 equivelent w/ launch control and type r base map... im pretty sure its obd1. could it be the ecu? also thats the main priority right now is fixing that, but also what are the ways to fix the other codes? My friends letting me try his ecu out of his GSR tomorrow to see if it fixes it, but untill then i can use all the help i can get. Thank you in advance for the help ​
Draft saved Draft deleted

Share This Page