1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b18 crx, wont rev past 3500

Discussion in 'ECU's, Electronics, and Tuning' started by oneslow_honda, May 20, 2008.

  1. oneslow_honda

    oneslow_honda New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    May 20, 2008
    hi, i am new to site. bought a 91crx with a b18 swap already done. been drivin it around for a month or 2. the other day i hit a dip in my dirt road and the car wont rev past 3500rpm. i replaced the throttle body, the tps sensor, and found some wiring that was loose. fixed all that. the car idles better but still wont go past 3500rpms. i have a pr4 computer. it acts like it is limp mode i have already ordered a new one. do you think it will help or is it somethin else. thanks for any input.
     
    Last edited: May 21, 2008
  2. oneslow_honda

    oneslow_honda New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    May 20, 2008
    somebody please give me a suggestion, i have done all i know how to do.
     
  3. BrutalB83

    BrutalB83 Brutal Moderator Moderator VIP

    Messages:
    11,620
    Likes Received:
    302
    Joined:
    Jun 24, 2006
    Location:
    Rochester Hills, MI
    Was the check engine light coming on?
     
  4. oneslow_honda

    oneslow_honda New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    May 20, 2008
    the chech engine light has been on since i bought the car. the guy i bought the car from did a hack job to the harness. i have broke out the notebook, and test light tryin to figure out what is what. i put the new computer on it today. it idled really good better than it has but it still won't go past 3500. i am thinkin i might just tear it all apart and re do it the right way. unless somebody has a suggestion. thanks
     
  5. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    get a new harrness..if he hacked it together,then it could be real bad,
     
  6. CRXRenegade91

    CRXRenegade91 New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Mar 21, 2007
    I have the exact same issue with my 88 Crx with a B18C1 running with a P28, a friend of mine recommended the MAP sensor. Ive replaced everything trying to narrow this down, everything except the MAP. So maybe start there :confused:
     
  7. phat87mazdarx7

    phat87mazdarx7 New Member

    Messages:
    46
    Likes Received:
    0
    Joined:
    Mar 12, 2007
    I have a 90 crx hf thaat did the same thing, the idiot I go the car from did a dual point to multi port swap. Yeah I know HF and SI were both MP, so I had to undo that and then it actually turned on. but once it turned on it was in limp mode(wont rev past 3500) so I checked my codes(little plug on the pass side near the computer, key off jump the 2 terminals together, then turn the key and the light starts flashing) my codes were for a fuel injector. so I pulled the wires off the ecu and off the injectors and got a wiring diagram, and sure as shit oone of the wires wasn't making a connection, so I ran it straight from the injector to the ECU(the injectors go from the ecu to th injector, then to a resister box, then back to the ecu, mine has a split on the side without the resister box) once i did that, i drove it for a month no prob, and took it to the track to run mid 8's, 1/8mile on a stock LS with and ebay intake pipe and old foam filter, and a brospeed axle back, 17's, full interior, and and my 230lbs fat ass, lol.
     
Verification:
Draft saved Draft deleted

Share This Page