1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B18C4 (B18C1) Swap Problems, Wont Start but have Fuel and Spark

Discussion in 'HYBRID -> EG-EK / DC' started by R883, Aug 17, 2009.

  1. R883

    R883 New Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Apr 20, 2008
    B18C4 (B18C1) Swap Problems, Wont Start but have Fuel and Spark -NOW RUNNINg-kind of

    Right i need some help

    I have just swapped a b18c4 (uk version of B18C1) into an EK and cannot get it to start
    I am stumped into as way

    Have have checked all i can think of and it doesn't change anything

    - I have fuel and have a spark
    - Running a P28 with a B18C4 map
    - Have put new earth leads on, cleaned them all up including the thermostat ground.
    - New plugs (correct gap), checked leads
    - New rotor arm and new dizzy cap
    - checked the cam timing (it was out but fixed that)
    - played with the ignition timing
    - 1 CEL for o2 sensor (away to sort that but it should still start)

    Dont know what else to do

    Anyone got any ideas ??
     
    Last edited: Oct 7, 2009
  2. R883

    R883 New Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Apr 20, 2008
    Just done a compression test the results are

    No. 1 = 202psi
    No. 2 = 208psi
    No. 3 = 202psi
    No. 4 = 202psi

    So everything looks fine their
    Dont know what else to look at
     
  3. R883

    R883 New Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Apr 20, 2008
    CEL now fixed still not starting :(
     
  4. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    check to see if the injectors are firing
     
  5. R883

    R883 New Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Apr 20, 2008
    Checked the injectors they are fine

    I have noticed a humming noise coming from my ivac anyone got any ideas what it is ?
     
  6. slowpoke707

    slowpoke707 New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Aug 21, 2009
    what year ecu u runnig change it and see if that starts and if you have a jumper hardness check that as well
     
  7. nicefighter80

    nicefighter80 New Member

    Messages:
    17
    Likes Received:
    0
    Joined:
    Jul 19, 2009
    having the same problem expect my b18c1 is obd2 and in a eg
     
  8. R883

    R883 New Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Apr 20, 2008
    i am running a p28 with a b18c4 map
    and connecting it with a harness

    I have tried it with my y8 ecu but it still wont start
     
  9. runner253

    runner253 New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Jan 2, 2009
    whats the deal with lsvtec not working on these new swaps
    JDm b18a w/2000 b16 si head crank but no start
     
  10. R883

    R883 New Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Apr 20, 2008
    :confused:
     
  11. R883

    R883 New Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Apr 20, 2008
  12. PortLuver

    PortLuver New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    May 8, 2009
    Location:
    Bx
    I beleive on newer honda motors you have a oil cut off sensor or oil pressure switch which ever you want to refer it as, check those, if ecu does not get a read it will cause engine not to start
     
  13. R883

    R883 New Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Apr 20, 2008
    Still not got this going yet

    not been near it in a bit
    i have checked the dizzy and realised that it is for a 1.6 vti

    is this ok ?
     
  14. Matts96HB

    Matts96HB . Moderator VIP

    Messages:
    6,483
    Likes Received:
    390
    Joined:
    Apr 16, 2006
    As long as the distributor you are using is for the same OBD, you should be fine. What OBD is the engine?
     
  15. R883

    R883 New Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Apr 20, 2008
    obd2a mate
    same for dizzy
     
  16. Matts96HB

    Matts96HB . Moderator VIP

    Messages:
    6,483
    Likes Received:
    390
    Joined:
    Apr 16, 2006
    Ok so you have spark, you have fuel, have you checked your timing?

    With proper spark, timing, and fuel an engine will start. Forget about everything else for now and just focus on making sure those three things are correct.
     
  17. 78civic

    78civic Junior Member

    Messages:
    725
    Likes Received:
    10
    Joined:
    Oct 28, 2004
    Location:
    NW MS, Y'all
    How long has the motor/injectors been sitting?
    Sometimes the pintles get gummed up and don't allow the fuel to squirt while everything else looks fine.
    Just pull them and soak the tips in carb/brake cleaner and lightly push the pintles in (they'll pop back out, well they should) several times until it feels cleaner.

    just my .02
    E
     
  18. R883

    R883 New Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Apr 20, 2008

    timing is bang on mate
     
  19. R883

    R883 New Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Apr 20, 2008
    i will give this a try

    cheers for your help
     
  20. dtob

    dtob New Member

    Messages:
    578
    Likes Received:
    2
    Joined:
    Mar 18, 2007
    If you've taken off the plug wires from the dizzy just make sure they are back on in the proper firing order, I took mine off and screwed it up putting them back on one time. Car wouldn't start.

    What model and year of car?? Is the engine out of a matching year or obd?

    Oh and make sure that your TPS and I think your MAP are plugged into the right sensor as well as your IACV and other sensors, they sometimes have the same plugs and can get mixed up if you didn't mark them when removing them from the old engine.
     
Verification:
Draft saved Draft deleted

Share This Page