1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B20 wont start

Discussion in 'Civic and CRX - EF' started by jswift, Dec 7, 2007.

  1. jswift

    jswift New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Jun 18, 2007
    Hey guys I have a 90 si and just put in a b20b into it, everything is wired up but it will not start. Lights work and fuel pump primes but nothing else happens. I think I maybe missing some grounds, can any of you give me some info on what grounds need to be where? I have been at this all week and have no clue what to do now. Please help!!!!
     
  2. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs
    make sure that the ground wire at the thermostat housing is connected
     

    Attached Files:

  3. jswift

    jswift New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Jun 18, 2007
    yeah that one is good, is there suppose to be another ground right next to it? because I see a whole where you can put on but not sure what its for.
     
  4. jswift

    jswift New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Jun 18, 2007
    Ok so it turns over now, I guess the ground to the starter was not strong enough. Anyway it will not start and stay on, sounds kinda weird too. A friend said maybe due to bad timing but I'm not sure.
     
  5. tido316

    tido316 New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Dec 16, 2007
    check your distributor because it might be no good i have the same problem. i fixed that like two days ago while i was doing my swap, but now i have another problem where i will turn on my motor it will shut of right away.
     
Verification:
Draft saved Draft deleted

Share This Page