1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

car turns on den turns off help plz

Discussion in 'HYBRID -> EG-EK / DC' started by chacal06, Nov 7, 2009.

  1. chacal06

    chacal06 New Member

    Messages:
    110
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    Location:
    los angeles CA
    I have a lil problem I just got my car bak from the mechanic changed the cams shaft and cam gears so my problem is that when ever I turn on my car it idles loww and it turns of the way for me to keep it on is to hold the gas a lil bit for a while and then it will stay on it won't turn off and when I'm drivin sometimes it idle low sometimes normal...I changed the idle air valve before I took it to the shop now I don't know what it could be ! Any help thanks
     
  2. iwishihadahb

    iwishihadahb New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Aug 5, 2009
    Location:
    maine
  3. chacal06

    chacal06 New Member

    Messages:
    110
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    Location:
    los angeles CA
    That's my other problem....I didn't know my heads are from a b16 so I bought a valve for a acura...do I have to buy it for the same yr ? I just figured out by lookin at some pictures that I have b16 manifold
     
  4. eg6sir

    eg6sir Supa Mod Moderator VIP

    Messages:
    21,703
    Likes Received:
    321
    Joined:
    Aug 17, 2005
    Location:
    661 BK CA
    how can you tell its a b16 IM ... there should be a casting on the back of the manifold ..
     
  5. chacal06

    chacal06 New Member

    Messages:
    110
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    Location:
    los angeles CA
    Well i seen some pictures and thats what it looks like....and my friend works in a place where they sell parts and he said that it also looks like the honda SI air valve...where can I read what kind of IM
     
  6. 1320scientist

    1320scientist New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Nov 26, 2009
    Location:
    N.J
    Sounds to me like the car is off timing. One time a car came to my shop and someone installed the cams 180% off.. So just overlook the timing marks
     
  7. chacal06

    chacal06 New Member

    Messages:
    110
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    Location:
    los angeles CA
    I had my cams replaced too and I just got my seals replace it doesn't idle so much like it used to... the guy told me he fixed my timin and now it kind of idle high when I turn it on but when I start drivin it just goes normal but I prefer to have it like that then idle low... thanks for the advice now I guess ama have to get used to it idlin high when I turn it on
     
Verification:
Draft saved Draft deleted

Share This Page