1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

civic spark and fuel help.

Discussion in 'Civic and del Sol - EG and EK' started by AHHVTEC, Jan 31, 2012.

  1. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    ok guys i need opinions on this. im working on a friends 94 civic, who ever had the car replaced the motor and ecu with a d15b7. the car was original a z6 car ex. he said he has been driving the car for a while now with no problems, the other day he was going down the road and the car just shuts off, so i check it out and i notice the fuel pump isn't coming on and there is no spark, so i replace the main relay, still no fuel or spark, so i go ahead and replace the distributor, still nothing no spark, all the fuses are good, but after the new parts no change. the only thing left that i can think of is a bad ecu. that's my next thing unless some one guides me different.
     
  2. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,414
    Likes Received:
    149
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    Stab in the dark.....ignition?
     
  3. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    well the key seems to be fine, it kicks back as it should and everything, and the timing belt is also good.im getting power to the dizzy also.
     
  4. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    ok i forgot to say this lol and i think i just answered my own thread lol, the check light is on but when i jump it nothing happens, it does not flash at all. if i remember correct that means bad ecu.
     
  5. serrilion

    serrilion In my own little world! VIP

    Messages:
    1,758
    Likes Received:
    42
    Joined:
    Aug 13, 2007
    Location:
    Vermont
    Hope this helps

    defined by CEL remaining on steady both without and with the service connector jumped) - indicates ECU power or ground problem when engine will not start; begin by checking the three main relay fuses and the G101 ground attached to the thermostat housing
     
  6. serrilion

    serrilion In my own little world! VIP

    Messages:
    1,758
    Likes Received:
    42
    Joined:
    Aug 13, 2007
    Location:
    Vermont
    I'd also check engine grounds... car will not start with out them lol
     
  7. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    it was a bad ecu, along with a brand new bad dizzy lol
     
  8. serrilion

    serrilion In my own little world! VIP

    Messages:
    1,758
    Likes Received:
    42
    Joined:
    Aug 13, 2007
    Location:
    Vermont
    That bites the cock, then again honda's are known for the dizzy but brand new ones? sigh* we had an ECU go on our loaner car the other day...
     
Verification:
Draft saved Draft deleted

Share This Page