1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DPFI to MPFI with D16Z6 swap.

Discussion in 'HYBRID -> ED-EF / DA' started by CrixSi91, May 1, 2011.

  1. CrixSi91

    CrixSi91 Junior Member

    Messages:
    113
    Likes Received:
    1
    Joined:
    Jul 9, 2006
    Location:
    Port Deposit, MD
    Ok guys here is what I have and what has been done. To start with the car is a 91 hatch Dx with the Z6 engine already in. We bought the car just like that. There was no engine harness or anything. I took a harness off another Dx in the junk yard. We wired it up to the Z6 engine changing and moving plugs as need. Then I add the 4 wires from the ECU. The 2 for the distributor and the 2 for the injectors. I also did away with the resistor cuz we are using 0bd2 injectors. We have a ECU jumper harness and we are using the p28 ECU. I did the mpfi to the stock harness and then pluged that into the jumper harness. Everything is hooked up but we are not getting any spark. We have power the distributor but no spark at the plugs. Does anyone have any ideas on what might be worng? If you have any other advice on this swap it will be greatly appriciated. Thanks.
     
  2. RHDism

    RHDism Right Hand Drive guru

    Messages:
    259
    Likes Received:
    9
    Joined:
    May 1, 2011
    How are you confirming spark to the plugs?

    Also, why are you using obd2 injectors, w an obd1 motor?
    They are both high impedance either way.
    Check w k2e2vin, Im mostly certain you will need a resistor box w your mpfi on a dx.
     
  3. CrixSi91

    CrixSi91 Junior Member

    Messages:
    113
    Likes Received:
    1
    Joined:
    Jul 9, 2006
    Location:
    Port Deposit, MD
    I'm checking for spark by putting a spark plug on the spark plug wire then holding the end of the spark plug against a valve cover bolt. There is no spark when the motor is turned over. Im using 0bd1 injectors, sorry hit the wrong button. I have a crx Dx that was already converted to mpfi and it has the 0bd1 injectors in it and there is no resistor on the car for them. So I should need a resistor box for this car. We have rebuilt the distributor and still no spark.
     
  4. RHDism

    RHDism Right Hand Drive guru

    Messages:
    259
    Likes Received:
    9
    Joined:
    May 1, 2011
    Resistor box would be needed for your injectors and the mpfi swap unless the car is a standard (base) model, not to be mistaken for standard tranny.

    This does not explain your no spark issue. EF civics are common for faulty main relays. When these relays go bad, you will not get fuel or spark.

    When you turn the key to the on position, do you hear the hum from the fuel pump
    and does the CEL illuminate then turn off after a few seconds? It is also very common for this problem to be intermittent. If yournot seeing the CEL or hearing a second click from the relay, it is most likely faulty or not wired correctly.

    Report back once you have inspected.
     
  5. RHDism

    RHDism Right Hand Drive guru

    Messages:
    259
    Likes Received:
    9
    Joined:
    May 1, 2011
    Also, by your user name CRX " si " . Your rex should have already been mpfi. :ph34r:
     
  6. CrixSi91

    CrixSi91 Junior Member

    Messages:
    113
    Likes Received:
    1
    Joined:
    Jul 9, 2006
    Location:
    Port Deposit, MD
    I will check on that next time I get overt the car. As for my name, yes when I started using hondaswap I did have a 91 crx Si. That project has been sold. The crx I have now is a 91 Dx and was converted to mpfi and does not have the resistor box for the injectors. I was sure we heard the fuel pump but i could be mistaken. I'll post back what we find out. Thanks for the info.
     
  7. crxhfz6

    crxhfz6 Member

    Messages:
    130
    Likes Received:
    0
    Joined:
    Oct 6, 2009
    Location:
    Manhattan, KS
    obd1 injectors do not need the resistor box
     
  8. RHDism

    RHDism Right Hand Drive guru

    Messages:
    259
    Likes Received:
    9
    Joined:
    May 1, 2011
    True.
    providing your doing completely away with obd 0.
     
  9. crxhfz6

    crxhfz6 Member

    Messages:
    130
    Likes Received:
    0
    Joined:
    Oct 6, 2009
    Location:
    Manhattan, KS
    well the OP said he was using obd1 injectors, regardless of anything else the box isnt needed
     
  10. RHDism

    RHDism Right Hand Drive guru

    Messages:
    259
    Likes Received:
    9
    Joined:
    May 1, 2011
    Chuck. I dont mean to argue with you.

    His set up is correct. He has stated he is running all obd1 components, no need for resistors.

    If he or anyone else that reads this thread decides to run an obd-0 ecu, with obd1 or obd2 injectors, the resistor box is a must to accomodate high impedance injectors.

    http://hondaswap.com/hybrid-ed-ef-da/dpfi-mpfi-obd0-obd1-516800/
     
    Last edited: May 4, 2011
  11. crxhfz6

    crxhfz6 Member

    Messages:
    130
    Likes Received:
    0
    Joined:
    Oct 6, 2009
    Location:
    Manhattan, KS
    odb0 ecu + resistor box + obd1 injectors = killing off injectors very shortly. obd1 injectors are saturated, so no resistor box regardless of ecu
     
  12. CrixSi91

    CrixSi91 Junior Member

    Messages:
    113
    Likes Received:
    1
    Joined:
    Jul 9, 2006
    Location:
    Port Deposit, MD
    Yes I have completely done away with the 0bd0 system and I am using all 0bd1 stuff (ECU, distributor, injectors ect). I was sure my research was correct about the resistor box an the whole dpfi to mpfi and Z6 swap. As for my issue with no spark, that has been fixed. Thanks to RHDism, all it needed was a new main relay. A big thanks to everyone.
     
  13. cardinalboy07

    cardinalboy07 New Member

    Messages:
    38
    Likes Received:
    0
    Joined:
    Nov 4, 2008
    Hey I'm doin. A y8 on a6 swap I'm using the y8 top end intake+injectos...now. I'm using a z6 dizzy which is odb1and odb1 p28ecu....my question is the dpfi to mpfi since I'm using odb2 injectors idon't need the res box rite? Buh how do I wire them? Do I do same steps at ecu wen wire injectors by running the 2 extra wires for inject #3 #4 ? We're do the wires tht wuld go into a res box go if I we're using odb1 injectors go?
    Do I jus follow all the steps for dpfi to mpfi up to res box? Alson if I do this do I need the jump harness for odb0 to odb1?
     
  14. CrixSi91

    CrixSi91 Junior Member

    Messages:
    113
    Likes Received:
    1
    Joined:
    Jul 9, 2006
    Location:
    Port Deposit, MD
    Start your own thread. Stop thread jacking.
     
  15. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,416
    Likes Received:
    152
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    So I am having a hard time with the resistor box having something to do with no spark.

    After you try to turn it over......take a plug out and smell for gas on the plug.

    I am going to guess and say there is an issue in the dizzy wiring and that is the reason behind no spark.
     
  16. CrixSi91

    CrixSi91 Junior Member

    Messages:
    113
    Likes Received:
    1
    Joined:
    Jul 9, 2006
    Location:
    Port Deposit, MD
    Are you asking for help? You need to start your own thread and provide as much detail as possible. Like what engine you have, car: make,model,year, also is it dpfi or mpfi. Be specific an you will get answers. Thread jacking will get you no where. As for my problem, if you read the thread you will see I solved the issue.
     
  17. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,416
    Likes Received:
    152
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    Look at my post count. Does my experience on here make you think I am thread jacking b/c I don't know how to start a thread? My Rides are below my post count.

    I was disputing the resistor box being anywhere close to the issue of no spark and thought the dizzy was your issue. Did not see you fixed the problem.

    A main relay fixed the issue of no spark?
     
    Last edited: Jul 27, 2011
  18. CrixSi91

    CrixSi91 Junior Member

    Messages:
    113
    Likes Received:
    1
    Joined:
    Jul 9, 2006
    Location:
    Port Deposit, MD
    Sorry about that. I check up on here with my phone while at work, Which ends up bein around 3am. I didn't meen any disrespect, just had a little trouble understanding if you where looking for help or not. When your tired and going to sleep is the only thing On your mind, you tend miss understand things. Yes my issue with no spark was due to the main relay was bad. All my wiring was correct, just a bad relay.
     
  19. CrixSi91

    CrixSi91 Junior Member

    Messages:
    113
    Likes Received:
    1
    Joined:
    Jul 9, 2006
    Location:
    Port Deposit, MD
    Sorry about that. I check up on here with my phone while at work, Which ends up bein around 3am. I didn't meen any disrespect, just had a little trouble understanding if you where looking for help or not. When your tired and going to sleep is the only thing On your mind, you tend miss understand things. Yes my issue with no spark was due to the main relay was bad. All my wiring was correct, just a bad relay.
     
Verification:
Draft saved Draft deleted

Share This Page