1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

electrical issue in my 89 civic sedan dx

Discussion in 'Civic and CRX - EF' started by 89y49rexsi, Aug 7, 2009.

  1. 89y49rexsi

    89y49rexsi New Member

    Messages:
    114
    Likes Received:
    0
    Joined:
    Aug 6, 2009
    Location:
    utah
    well i didnt notice this until i was on my way home after buying the car but the problem is that when i turn on the left blinker my rpm guage goes nutz and starts jumping all over the place. before i put in the si guages it was the temp guage. im thinking that it is a short or a bad ground if anyone has had this problem please let me know what it took to fix it. cuz it bugs the piss out of me. thanks guys
     
  2. 89y49rexsi

    89y49rexsi New Member

    Messages:
    114
    Likes Received:
    0
    Joined:
    Aug 6, 2009
    Location:
    utah
    bump i guess nobody knows
     
  3. 89y49rexsi

    89y49rexsi New Member

    Messages:
    114
    Likes Received:
    0
    Joined:
    Aug 6, 2009
    Location:
    utah
    comon guys i know that someone else has had this problem before help me out
     
  4. Fernpatch

    Fernpatch Member

    Messages:
    572
    Likes Received:
    19
    Joined:
    Jul 28, 2008
    Location:
    Bellingham,WA
    Start with checking your grounds, I have not personally had that problem but it does sound like a bad ground causing a back feed.
     
  5. 89y49rexsi

    89y49rexsi New Member

    Messages:
    114
    Likes Received:
    0
    Joined:
    Aug 6, 2009
    Location:
    utah
    thats what i was thinking i checked and tightend the one under the dash by the steering column and it still does this what other grounds are there?
     
  6. Fernpatch

    Fernpatch Member

    Messages:
    572
    Likes Received:
    19
    Joined:
    Jul 28, 2008
    Location:
    Bellingham,WA
    Do you have a helm/haynes/chiltons manual for your car? one of those should have a complete list of grounds and locations. If not let me know and I will see what I can scrounge for you.
     
  7. 89y49rexsi

    89y49rexsi New Member

    Messages:
    114
    Likes Received:
    0
    Joined:
    Aug 6, 2009
    Location:
    utah
    i dont have one right now but i guess i will get one in the near future. but this bugs the hell out of me--and why would my fuel guage not work with the si cluster when it worked with the stock cluster that bugs me as well
     
Verification:
Draft saved Draft deleted

Share This Page