1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Gsr turbo need help running weird.

Discussion in 'Forced Induction' started by dillonboy, Mar 31, 2010.

  1. dillonboy

    dillonboy New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Mar 31, 2010
    I have a b18c1 turbo running on 10 pounds and here is the problem. When i just try to drive it around town it jolts around and acts like it needs more fuel.. but it ideals fine and when i get on it there is no problems at all. however when i just hold the gas pedal at a certain point the RPMs go up and will stay were i want them for about 6 seconds then they drop back down then jump up again. i never had this problem before with the car. so any one have an idea what it could be. :eek: Thanks
     
  2. Matts96HB

    Matts96HB . Moderator VIP

    Messages:
    6,482
    Likes Received:
    390
    Joined:
    Apr 16, 2006
    are you absolutely sure it is not the tune?
    also, moved to forced induction
     
  3. dillonboy

    dillonboy New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Mar 31, 2010
    hey I got to EWU by the way. any ways I never had problems with the tune before. This happens only when I hold the gas pedal at a certain point.
     
  4. Magana559

    Magana559 The Warden

    Messages:
    2,568
    Likes Received:
    42
    Joined:
    Aug 9, 2008
    Location:
    fresno Ca
    take it back to the tuner. shouldnt be acting like that.
     
  5. Matts96HB

    Matts96HB . Moderator VIP

    Messages:
    6,482
    Likes Received:
    390
    Joined:
    Apr 16, 2006
    nice man, wait is this in a blue civic si?

    anyway, are there any CEL's? thatd be the first place id start
    knowing that the car is tuned, the cel is probably disabled or used as a shift light, so you should try pulling codes off of the ecu and see if you get anything
     
  6. spectacle

    spectacle Senior Member

    Messages:
    898
    Likes Received:
    0
    Joined:
    Aug 23, 2003
    Location:
    St. Petersburg, Fl
    What engine managment?
    What injectors?
    What the fuel setup?
    Who did the tune? Can you post a datalog?

    Need a lot more info if you want help. Sounds like a may be a mechanical problem like a stuck throttle linkage or something like that.
     
  7. eg6turboLs

    eg6turboLs New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Apr 12, 2010
    Could be ur tps sensor cuz I had a ls turbo and it was doing that exact same thing, might need a adjusting or replace. I'm not saying this could be ur problem but that fix mine...good luck wit urz, I hated it wen it happen to me. Also could be a boost leak....
     
  8. dillonboy

    dillonboy New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Mar 31, 2010
    IT wAS THE TPS THANKS GUY
     
Verification:
Draft saved Draft deleted

Share This Page