1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help code 23 on my 92 si with b16a

Discussion in 'ECU's, Electronics, and Tuning' started by nolimitlowrider, Jul 2, 2007.

  1. nolimitlowrider

    nolimitlowrider New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Jul 2, 2007
    Hey guys
    got my swap done today. I did the jdm b16a into my 92 civic si I am running a del sol P30 with del sol wiring harness, but its not the dohc harness I put in the knock sensor wire from my jdm harness. I hooked up the knock sensor wire just as it was done on the JDM harness I also hooked up the grounding shielding wire thats around the knock sensor wire, and also have a jdm P30 ecu And when i drive the car for a lil bit and get on it a lil i get check eng. light And it gives a code 23. knock sensor?? and my autozone book says it dont have a code 23 my 92 civic that is. maybe a del sol with the dohc may have that code...anyone know?? Thanks
     
  2. 9399b16

    9399b16 New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Jun 25, 2007
    i think it is for the v tec same a code 22 maybe yuor ground or hot wire is wrong check it out
     
  3. Black Widow g2

    Black Widow g2 *princess*

    Messages:
    3,599
    Likes Received:
    31
    Joined:
    Oct 18, 2004
    Location:
    California
    23
    Accord Civic CRV CRX Del Sol Odyssey Prelude
    98 * 96-98 n/a n/a 94-97 n/a 92-98 KS (Knock Sensor)
    defective circuit or unplugged / defective sensor

    the ecu is looking for a signal from your knock sensor and apparently not finding it. Are you sure the wiring is done properly?
     
  4. nolimitlowrider

    nolimitlowrider New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Jul 2, 2007
    hello
    Yes i have checked the wiring over good even took an ohm meter to the plug to the ecu pin and its good. I took the knock sensor out today and unpluged it and the eng light wont come on until it gets hot. should it even run without it hooked up? and the pin it in D3 on the ecu plug. So im not sure whats wrong. Anyone know how to test a knock sensor?? I had 2 sensors on it so far. Thanks for any help at all.
     
  5. Black Widow g2

    Black Widow g2 *princess*

    Messages:
    3,599
    Likes Received:
    31
    Joined:
    Oct 18, 2004
    Location:
    California
    i know you can disable the knock sensor in the ecu... mine isn't, but i think it makes sense in these situations... sounds like there's a problem with the ecu or the sensor... possibly the board on the ecu for the knock is messed up? i'm not good with this stuff, my boyfriend is... but i can ask him when he gets home what he thinks.
     
Verification:
Draft saved Draft deleted

Share This Page