1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

help just did sohc zc swap

Discussion in 'HYBRID -> ED-EF / DA' started by Seany B, Aug 28, 2004.

  1. Seany B

    Seany B Junior Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Aug 28, 2004
    car runs rough and sputters when i reach 3000 rpm until it stalls.
    any reasons?
    i have a dx harness and a pm6 ecu on a zc..
     
  2. phunky.buddha

    phunky.buddha Admin with a big stick Admin VIP

    Messages:
    28,465
    Likes Received:
    228
    Joined:
    Sep 30, 2002
    Location:
    Dallas / Fort Worth, TX
    Plugs? Improper wiring for 2 injectors? ???
     
  3. Seany B

    Seany B Junior Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Aug 28, 2004
    replaced the plugs and distributor. and checked wiring.
     
  4. phunky.buddha

    phunky.buddha Admin with a big stick Admin VIP

    Messages:
    28,465
    Likes Received:
    228
    Joined:
    Sep 30, 2002
    Location:
    Dallas / Fort Worth, TX
    So you're properly wired for 4 injectors?
     
  5. Seany B

    Seany B Junior Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Aug 28, 2004
    yes the 4 injectors are properly wired.
    any other ideas?
     
  6. phunky.buddha

    phunky.buddha Admin with a big stick Admin VIP

    Messages:
    28,465
    Likes Received:
    228
    Joined:
    Sep 30, 2002
    Location:
    Dallas / Fort Worth, TX
  7. ThrowbackHatch89DX

    ThrowbackHatch89DX Junior Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Jun 10, 2004
    all i can say is check you plugs and wire cuz my car was doing somethine similar and it was because my plugs and wires were tore up.
     
  8. hcivic.com

    hcivic.com Senior Member

    Messages:
    4,571
    Likes Received:
    2
    Joined:
    Jan 7, 2003
    Location:
    Calgary Alberta canada
    you wired in a resitor right
     
  9. Seany B

    Seany B Junior Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Aug 28, 2004
    i wired in a resistor. and im getting new wires soon ive already got new plugs and distributor.
     
  10. limited-xposure

    limited-xposure Junior Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jun 25, 2004
    Make sure your plug wires are int he proper spot. my friends car was doing the same at one point. He found out that the wires were in the wrong spot!
     
  11. mikesphat

    mikesphat Senior Member

    Messages:
    331
    Likes Received:
    0
    Joined:
    Nov 27, 2003
    dont forget to reverse the two outer wires on the tps... otherwise the ecu will think the engine is at full throttle when its idling and vice versa... just throwing that out there...
     
  12. Seany B

    Seany B Junior Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Aug 28, 2004
    ok i have all of that done so it goes to a auto shop tommorow because it still does the same thing
     
  13. cheese9988

    cheese9988 Senior Member VIP

    Messages:
    1,990
    Likes Received:
    251
    Joined:
    Apr 25, 2003
    Location:
    Lowell, MA
    I had that exact problem on mine, runs ok at idle and then rev is up and it want to stall. There were two "ports" on the back of my intake manifold I had to plug up, check for those (if you even have em). If you plug them reset the ecu first.
     
  14. vtec84lude

    vtec84lude Junior Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Sep 6, 2004
    Location:
    Washington DC
    Is the MIL on and if so what code/s?
     
  15. Seany B

    Seany B Junior Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Aug 28, 2004
    Turned out to be the TPS so that will be changed by tommorow and then I'll see what happens.
     
  16. Seany B

    Seany B Junior Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Aug 28, 2004
    they put in the tps and there was no change then the diagnostics machine they had fryed. soooo no clue now... anyone?
     
  17. Seany B

    Seany B Junior Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Aug 28, 2004
    Ok rewired and everything is good besides the throttle cable... runs great. thx for the help
     
  18. juba allen

    juba allen New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Feb 26, 2009
Verification:
Draft saved Draft deleted

Share This Page