1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

NEED HELP on 97 Jeep Gr. Cherokee

Discussion in 'Other Vehicle Discussions' started by craiger, Oct 2, 2008.

  1. craiger

    craiger New Member

    Messages:
    81
    Likes Received:
    0
    Joined:
    Aug 27, 2008
    Location:
    Austin, Texas
    Hello. I am having a problem with my 97 Jeep Grand Cherokee Laredo. It has a straight 6 cylinder motor, AT tranny. It will start for 2-3 seconds then dies. If I rev it up it will die, if I let it idle it will die.

    Now here is the good, I have another identical Jeep Gr. Cherokee that I have switched many parts already on and off of it to check out what the hell is going on. So far no luck. Here is what I have switched: Computer, Coil, Pick up module, MAP Sensor. The running Jeep still works when I have taken these parts off of the non-running Jeep. So I know that these parts are not the problem .

    I initially thought it was a fuel problem but it is reading 50 psi at the fuel rail line.

    Please Help me out here.
     
  2. Dustin_m

    Dustin_m Active Member

    Messages:
    4,603
    Likes Received:
    16
    Joined:
    May 21, 2003
    Location:
    San Diego, CA
    Go over to NAXJA.org and check out the forums. It's an XJ board but since your ZJ has the 4.0, you might be able to figure out whats wrong. Specifically, check out the OEM Tech forum. Also, you could always register and post up in the regional forums to see if theres anyone near you who can help out. The guys on there, for the most part, are really cool and willing to help each other out.
     
    Last edited: Oct 2, 2008
Verification:
Draft saved Draft deleted

Share This Page