1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

p75 ecu with JUN Racing chip

Discussion in 'ECU's, Electronics, and Tuning' started by K20SA02, Aug 24, 2006.

  1. K20SA02

    K20SA02 New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Aug 24, 2006
    i am currently helping a friend install a JUN racing chip into a p75 ecu how ever i can't get it to wor properly because there is no R54 location for the suplied resistor. anyone heard of this problem before?
     
  2. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    54
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    do your feiends a favor and throw that program out...

    unless he has 13:1+ compression, and stage 3 cams, its going to run peg-rich, make shit for power, and will eat gas like a v8.


    As for your actual chipping issue.... are you sure its an obd1 p75?
     
  3. K20SA02

    K20SA02 New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Aug 24, 2006
    i am possitive that it is an obd1 p75 and have since found postings in other places where ppl have had similar issues because the "r54" location isn't there how ever i have yet to find a solution :(...i am however greatful for your input on the performance issues...he currently has short ram intake, dc sports header, greddy exaust, fuel presure reg., and aem cam gears installed so it might not be such a good idea for him to chip his computer yet...im still trying to do somemore research on it thou and any more input would be greatly appreciated.
     
  4. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    54
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    chipping is ok at any step... but you need to run a custom program... not a generic one built for 220whp all motor beasts by a jdm tuning factory. your 140hp LS doesn't need half of what that chip is going to put out in terms of fuel... not mention, jun surely doesn't run LS motors.... sounds like you got an ebay special with someone claiming its a Jun chip, but it could be anything. I wouldn't touch a single motor with that chip.
    I'm sure there's someone here who can help out and get you a base map for like $10.

    again, i have no info on the r54... have you tried pgmfi.org ?
     
  5. K20SA02

    K20SA02 New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Aug 24, 2006
    you hit the nail on the head....he said he got the chip off of ebay and after reading your replys to my post he has changed his mind about putting the chip in now....guess he figures its hard to argue with good reason...lol
    thanks for you input on the situation and thanks for saving me the trouble of having to try and figure it all out :)
     
Verification:
Draft saved Draft deleted

Share This Page