1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

plz hlp got a big issue..

Discussion in 'Integra' started by 93tegrars, Aug 23, 2009.

  1. 93tegrars

    93tegrars New Member

    Messages:
    15
    Likes Received:
    0
    Joined:
    May 9, 2009
    Location:
    Toronto , Canada
    I got a 93 integra n just today this started but its difficult to put in any gear , the clutch pedal feels soft , and I get a strange vibration/pulsation coming off of the clutch pedal only. also at 1 point I started to reverse n everything in the car was shaking/dragging feeling as I was reverseing . clutch , cable, low gear oil or tranny issue . any help would be greatly appreciated , thanks .
     
  2. 91integraXSI

    91integraXSI New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Aug 26, 2009
    Location:
    Bakersfield, Ca
    seems to me that your preassure plate is messed up. i dont see where the clutch pedal pulsation comes into play but if i were you, i would pull off the transmission and check the pressure plate and clutch disc to see if there is anything unusual with them, if not then your tranny just took a dump
     
  3. jdmacuraH22

    jdmacuraH22 New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Sep 1, 2009
    Location:
    Sc
    I had the same problem in my 2000 gsr and when we took the tranny off it was the clutch where one of the springs had broke off and got stuck by the pressure plate not letting it into gear
     
Verification:
Draft saved Draft deleted

Share This Page