1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Possible fuel filter?

Discussion in 'Civic and CRX - EF' started by EF9_Hatch, Sep 23, 2007.

  1. EF9_Hatch

    EF9_Hatch Yeah

    Messages:
    1,012
    Likes Received:
    38
    Joined:
    May 1, 2007
    Location:
    Coraopolis, PA
    Hey hows it goin, I have an 89 DX hatch with the D15B2 turd in it. It has 211K + miles on it. Recently it seems like its bogging out on me. Whenever i start it, it seems like it wants to stall. I rev it up a little bit and it idles fine. Whenever i get on it in first gear it will go to 20 then like seem like it stops getting fuel at high RPMs. It does the same thing when i do it in 2nd. After 2nd it stops doing it though. And it only does it for the first 10 minutes of driving. After it warms up its fine. Now yesterday i was driving home from work and sitting at a red light and it stalled? just randomly. It has never done that before, but it started right back up just fine. If i let it sit there it keeps wanting to stall but it never does. My friend thinks it could be the fuel filter but im not sure,
    Any help/info is greatly appreciated THANKS!
     
    1 person likes this.
  2. dacheat

    dacheat ..is grounded.

    Messages:
    4,216
    Likes Received:
    205
    Joined:
    Jul 7, 2007
    Location:
    strongbadia
    i'm gonna go with cat converter if it is stock, as what you describe sounds a lot like what my 89 Si did right before the catalyst asploded in mine and started blocking flow. second runner up sounds like maybe ignition module in distributor.
     
  3. EF9_Hatch

    EF9_Hatch Yeah

    Messages:
    1,012
    Likes Received:
    38
    Joined:
    May 1, 2007
    Location:
    Coraopolis, PA
    Dont have a cat, straight pipe after the header. Not sure about the ignition module tho. Thanks for ur help though lol
     
  4. EF9_Hatch

    EF9_Hatch Yeah

    Messages:
    1,012
    Likes Received:
    38
    Joined:
    May 1, 2007
    Location:
    Coraopolis, PA
    Does anyone else have any ideas on what this could be?
     
  5. get_nick

    get_nick These snozzberries taste like snozzberries... VIP

    Messages:
    11,937
    Likes Received:
    1,056
    Joined:
    Apr 21, 2003
    Location:
    Washington State
    check the timing. could also be fouled plugs, clogged injectors, water in the fuel. lots of things.
     
  6. EF9_Hatch

    EF9_Hatch Yeah

    Messages:
    1,012
    Likes Received:
    38
    Joined:
    May 1, 2007
    Location:
    Coraopolis, PA
    o ok, we just changed the timing belt/water pump and everything was lined up right but ill have to check it out, i did the plugs like a month ago and the injectors could be. Does that injector cleaner really work?
    Thanks for the help thought!
     
  7. get_nick

    get_nick These snozzberries taste like snozzberries... VIP

    Messages:
    11,937
    Likes Received:
    1,056
    Joined:
    Apr 21, 2003
    Location:
    Washington State
    if you just changed the timing belt, i would get a timing light or take it to a shop and have them do it. thats what my guess would be.
     
  8. EF9_Hatch

    EF9_Hatch Yeah

    Messages:
    1,012
    Likes Received:
    38
    Joined:
    May 1, 2007
    Location:
    Coraopolis, PA
    Ok ill have to do that, thanks man
     
  9. nbirkmyre

    nbirkmyre New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Oct 6, 2006
    Location:
    Northern Ireland
    how could it be the timing if its ok when it warms up?
     
Verification:
Draft saved Draft deleted

Share This Page