1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

speedometer problem

Discussion in 'HYBRID -> BA-BB /CA-CD' started by l_toknee_l, Sep 24, 2003.

  1. l_toknee_l

    l_toknee_l Junior Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Oct 23, 2002
    just wondering if anyone could help me out . i drive a 94 accord lx automatic . while i was driving down the highway i noticed my D4 light started blinking and then next thing my speedometer dropped to zero and stayed there since . later the engine light came on too . i thought it might just be a sensor or a blown fuse but i dont know what to do . any suggestions ?! thanks .
     
  2. dohcvtec_accord

    dohcvtec_accord WRX Sellout

    Messages:
    8,433
    Likes Received:
    1
    Joined:
    Sep 29, 2002
    Location:
    The left lane
    Why don't you pull the code first and see what it is?
     
  3. l_toknee_l

    l_toknee_l Junior Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Oct 23, 2002
    how do you pull codes and which ones ?
     
  4. dohcvtec_accord

    dohcvtec_accord WRX Sellout

    Messages:
    8,433
    Likes Received:
    1
    Joined:
    Sep 29, 2002
    Location:
    The left lane
  5. l_toknee_l

    l_toknee_l Junior Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Oct 23, 2002
    thanks . i just tried it and it blinked 1 long and 7 short . so i am guessing it is a code 17 . i believe that it is the speed sensor right ? well what do i do now ?
     
  6. dspeed

    dspeed Junior Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Oct 19, 2002
    I had the same problem, it threw the same code (17) and when i changed my speedometer cable, the CEL turned off.
     
  7. l_toknee_l

    l_toknee_l Junior Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Oct 23, 2002
    thanks . so i guess all i have to do now is replace it . how much does it cost for a new speed sensor cable ?!
     
  8. BigJ

    BigJ I'm just about that action Boss. VIP

    Messages:
    11,090
    Likes Received:
    408
    Joined:
    Oct 4, 2002
    Location:
    Washington
    You wouldn't need a cable, but yet a Vehicle speed sensor, the actual thing that goes in the transmission.
     
  9. l_toknee_l

    l_toknee_l Junior Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Oct 23, 2002
    nevermind . i just called up honda and they told me it would be around 120 . goddamm . would it be a problem if i didnt replace it ? ahaha its not like i really need it . o well thanks for all the help guys .
     
  10. l_toknee_l

    l_toknee_l Junior Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Oct 23, 2002
    i was wondering . could i use a speed sensor off a prelude or an accord ex tranny ?
     
  11. tab

    tab Super Moderator

    Messages:
    3,839
    Likes Received:
    46
    Joined:
    Jan 10, 2003
    Location:
    Aberdeen, Washington State
    Maybe, check an interchange manual, or have your local Honda parts dealer check the numbers to see if they match. 90-97 are pretty close to one another, and they probably share parts, or are the same. I'd try 90-95 first.
     
  12. l_toknee_l

    l_toknee_l Junior Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Oct 23, 2002
    thanks for all the help . i just used a sensor off a prelude si and it is working great .
     
Verification:
Draft saved Draft deleted

Share This Page