CEL codes 14/22

We may earn a small commission from affiliate links and paid advertisements. Terms


New Member
Hi all,

I have searched but unfortunately can't search for a 2 character thread. I just purchased a 95 OBD1 accord EX w/h22a installed. It throws immediate CEL codes 14/22, I have tried resetting it but the code comes on immediately. From searching, I found the following:

14- Accord Civic CRV CRX Del Sol Odyssey Prelude
88-98 88-98 97-98 88-91 93-97 95-98 88-98
IAC Valve (Idle Air Control)
defective circuit or unplugged / defective sensor

22*- Accord Civic CRV CRX Del Sol Odyssey Prelude
94-98 92-98 n/a n/a 93-97 98 93-98`
VTEC Oil Pressure Switch
defective circuit or unplugged / defective oil pressure switch
* not a valid code if car does not have a VTEC engine

From what I've read- the 95 EX should have been VTEC and everything looks to be connected around the vtec solenoid. There is only one wire that I am questioning but may mean nothing

from the below pic


there is a green plugin then under that there is a gray w/another gray hanging under it just like in my car. The other gray one seems to be the same type of connection as the one in the pic above plugged in but it's too short and won't reach. Is this my issue? If not- can anyone give me an insight as to where I should start?

does the car's idle surge up and down?? i had the same problem with my IACV and i was told don't worry about it because it would stop after driving it for awhile, and as far as your vtec issue, well the plug below if it only has one wire in it then try it, if not then dude is right thatd be your primary O2 plug, other than that man, don't know what to tell ya
The idle doesn't surge up and down. But once I start to drive, I have to use the clutch to control the car or it will buck and jump. Also if the A/C or steering wheel load changes- the car does not hold steady rpm's. I solved the vtec issue by jumping two wires. Thanks for the reply bro- I have a new IACV en route.
i had that same problem with my iacv, here it was my plug backing out of the sensor, it wouldn't stay plugged in, and i had to use the clutch or be wide open throttle, so check your plug too you might have something stuck in there or it might be the iacv itself, and right on man no problem....