Check engine light fixed, then not fixed

We may earn a small commission from affiliate links and paid advertisements. Terms


New Member
Car- 1994 civic ex
Engine- B18C obd2 (a or b i don't know)
Engine Harness- harness that came with engine
ECU- xxxxx-P72-A01

Ok, so I put a B18c into my civic. Moved A20 to A17, gave my IAB a switched 12v power source (12v when key is in run position, see picture)


and then ran the knock sensor wire to D3.'s walk through said that if you had a ex or si you didn't have to worry about wiring vtec cuz my motor was vtec. so I start it up, hard 22 (vtec pressure switch) is thrown, rev limiter kicks in at 6500 rpm. So I looked on, was looking for the vtec pressure switch on my motor and couldn't find it (see picture)

coolant temp.JPG

all I could find was a coolant switch so i grounded the vtec pressure switch from the ecu, test drove it, vtec worked, rev limiter was at about 8000rpms now. yay!!! So I hook up my stock exhaust temporairily untill later this week when I can go to the exhaust shop and have my exhaust made and call it good.

So I go to my friends house, take him for a ride, in 3rd or 4th gear at 7000rpm's check engine light comes on, vtec isn't engaging anymore. CEL is 22 but it clears when I turn the car off so its not a hard code. I've been reading these forums non-stop for about 2 days trying to get ideas. soo did I screw something up? is my vtec pressure switch somewheres else? I thought I heard somewhere that some jdm engines don't have a vtec pressure switch. Any ideas would be helpful, tell me if i screwed up, call me a dumbass, but above all help.


and i know that the wiring splice for the iab sucks, my soldering iron is at work so that is going to get solder and taped tomorrow so don't make fun of that.

EDIT: Just FYI my engine is jdm and my ecu is usdm so could that be causing the problem? I talked to someone and they said that i have to buy a usdm vtec soleniod/pressureswitch assembly to make my cel go off... but I am planning on buying a apex v-afc II later on so I was wonering if with the v-afc I could bypass the pressure switch to make the cel go off and the vtec engage.

also my engine lvl is good (4.2 qts with a new filter) and I tried bypassing the pressure switch by jumping a4 to d6 at the ecu to no avail.

Last edited:


New Member
So today at lunch I was bored, hooked up my stock p28 ex ecu, no cel, vtec worked, so I took the vtec pressure switch off of my d16, tap and drilled it into the vtec solenoid plate and used my p72 and everything works now, so you can lock this thread i guess. thanks