1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

90 crx si... cel but no code????

Discussion in 'Civic and CRX - EF' started by Doug2479, Apr 23, 2011.

  1. Doug2479

    Doug2479 New Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Apr 23, 2011
    90 crx si ... dohc zc .... check engine light but no error code????

    I have validated the ecu will throw a code by pulling an injector wire... it throws a 16... like it should. I clear the error. test drive, have a miss and low power.

    has new plugs, wires, cap & button.

    ??? any help would be great :)
     
  2. crxhfz6

    crxhfz6 Member

    Messages:
    130
    Likes Received:
    0
    Joined:
    Oct 6, 2009
    Location:
    Manhattan, KS
    so the check engine light is on but it doesnt show any codes?
     
  3. Doug2479

    Doug2479 New Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Apr 23, 2011
    correct, cel comes on while driving around 2k rpm and up... off below that. runs crappy.
    After this I pulled an injector wire and it threw code 16 ... like it should.

    I cleared the error and test drove again.... same result... misfire / low power. CEL with no code.
    ???
     
  4. crxhfz6

    crxhfz6 Member

    Messages:
    130
    Likes Received:
    0
    Joined:
    Oct 6, 2009
    Location:
    Manhattan, KS
    fuel filter or pump? check those and if you have another ecu you could try it out
     
  5. Doug2479

    Doug2479 New Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Apr 23, 2011
    Replaced fuel pump and filter.
    Have the power back and it holds an idle, big improvement.
    I still have a miss that's there all the time, except sometimes at higher RPM.
    Takes longer, but the check engine light comes on, but no code again.
     
  6. crxhfz6

    crxhfz6 Member

    Messages:
    130
    Likes Received:
    0
    Joined:
    Oct 6, 2009
    Location:
    Manhattan, KS
    runs some fuel system cleaner in it, make sure the timing is ok(cam and ignition), and make sure spark is good. if thats all good try and find a spare ecu to test and see what it does
     
  7. Doug2479

    Doug2479 New Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Apr 23, 2011
    Update,
    drove the car to work yesterday, had a small miss but ran decent to work. Half way home started acting up, limped along the side of the hwy... but got home. ECU was flashing code 1, so I replaced the o2 sensor and it ran the best I have ever seen it run... for about 5minutes.
    Back to miss / no power... cel but no error codes.... ECU is on the way. Anybody ever have this kind of problem?
     
  8. Doug2479

    Doug2479 New Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Apr 23, 2011
    dizzy timing off a little

    replaced the ecu... pm6 same as before.
    I put a jumper on the connector ( i think) 90 crx si... inside pass side blue connector... it doesn't have a cap

    I can only get the middle red line to almost the front side of the outside of the plastic site ... the bigger one ( that has the notch cut out). When I drive it like that its fine up to 5K and falls on its face, stop and start... good to about 4k and falls again... the longer you drive it like that the more it loses ... Is the cam timing wrong?
     
  9. Doug2479

    Doug2479 New Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Apr 23, 2011
    I have verified the cam timing, TDC white timing mark, cam gear is up, rotor button pointing to #1 ............ do i have a bad dizzy or wiring? Don't have a spare dizzy to swap, would have to purchase one.
     
  10. crxhfz6

    crxhfz6 Member

    Messages:
    130
    Likes Received:
    0
    Joined:
    Oct 6, 2009
    Location:
    Manhattan, KS
    is the cel still on? and check your fuel pump to make sure its good, and all grounds are good.
     
  11. Doug2479

    Doug2479 New Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Apr 23, 2011
    have already replaced fuel pump & filter, plugs, wires, cap, button, ecu.
     
  12. 90_EF_Hatch

    90_EF_Hatch Señor Member

    Messages:
    1,498
    Likes Received:
    41
    Joined:
    Oct 30, 2007
    Location:
    Dallas Texas
    just throwing it out there. I had a bunch of problems with my acura and completely replaced everything in my dizzy. (cap rotor ICM plugs) As soon as i went a bought a completely new dizzy the problems all vanished and it ran like a champ.

    NOT saying its the problem. But you can replace all the parts of a dizzy and it still be fucked
     
  13. Doug2479

    Doug2479 New Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Apr 23, 2011
    still chasing mystery. I can't get the timing set. The cam, crank, n dizzy all correct. Put the jumper on and the closest I can get is the 1st of the 3 timing marks, Things falls on its face under load after a few minutes of driving. ?????
    have either new or swapped w known good parts: ecu n dizzy. Fuel pump and filter are new. redone all grounds even have a ground running direct to ecu chasis to batt neg. I can leave the jumper in and it will drive great for a while. I can shut it down and startup and it flys for a while.

    HELP????
     
Verification:
Draft saved Draft deleted

Share This Page