1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

code 10 and 4 after mpfi

Discussion in 'HYBRID -> ED-EF / DA' started by J89EF9, Apr 28, 2008.

  1. J89EF9

    J89EF9 New Member

    Messages:
    25
    Likes Received:
    1
    Joined:
    Mar 29, 2007
    Location:
    nor*cal
    yep its me again lol
    after a non satisfactory result of swaping an EX harness in my sedan i went back to the yunk yard and got a stock DX harness engine/underdash. so i swapped them in again. modified the DX engine harness with the Si one i had for dizzy and injectors. ran the C1, C2, A3, A7 from the ECU. matched all my wires double checked everything and when i was ready to start it my ECU went bad i had check engine light on theres was no spark and the ecu wouldnt blink when i opened the switch. so i grabbed an extra PR4 from my DA and tried it on i know i wont work on the car just wanted to make sure it was the ECU and not the wiring and i was right it was the ECU.. When i plugged PR4 it was throwing code 4 and 10 i dunno if its bcuz of the ECU or bcuz my wiring is messed up lol. today i will try to get a PM6 and see whats up anyhow i also have a couple of plugs on the SI manifold that i dunno if i can wire them from the DX i took some pics one is attached to the monifold on the left side when i had the Si harness on it had a plug for it but on the DX im not sure. and the other one hangs on the back of the manifold its a rectangular plug with 2 wires going to it any help would be appreciated
     

    Attached Files:

  2. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs
    in the first picture, that is the Intake Air Temp sensor - that is why you have a code 6 - connector for it has 2-wires, red with yellow stripe and green with white stripe

    in the second picture, i assume that the connector you have circled comes off of the solenoid that is right below it in the picture - that is the Fast Idle Control Valve on the Si intake manifold - you won't have wiring for it on the DX harness - you don't really need the FICV - it just boosts the idle slightly when ambient air temp is below -10C (14F) - just leave it not connected and plug the vacuum ports on the solenoid

    code 4 is the Crank Sensor and usually means that your distributor is bad or that the wiring is not correct - did you move the orange wire from ECU pin C1 to ECU pin B10 and the white wire from ECU pin C2 to ECU pin B12? - these are the wires for the crank sensor which gives you code 4
     
  3. J89EF9

    J89EF9 New Member

    Messages:
    25
    Likes Received:
    1
    Joined:
    Mar 29, 2007
    Location:
    nor*cal
    yeah i moved those. but i have a question..
    on the instructions said that B12 should be empty
    but on my car there is a red/white wire there
    so what i did i cut that wire and attached it to C2
    i dunno if that was right or should i just left it there?
    oh and one more thing is it possible to make it run with
    a PR4 ECU while i get the PM6 ?
    thanks alot
     
  4. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs
    you should have just removed the existing wire at B12 - that wire is for the shift lock on automatic transmission cars - if you cut the wire to B12 and then cut the wire that went to C2 and connected the wire that went to C2 to the portion of B12 still in the ECU, you will be o.k.

    yes, it will run with PR4 but not very well - too rich
     
  5. J89EF9

    J89EF9 New Member

    Messages:
    25
    Likes Received:
    1
    Joined:
    Mar 29, 2007
    Location:
    nor*cal
    It runs =p

    I checked all my wiring everything was good but it still wouldnt start so i thought it might be the distributor so i tried my friends on it and it started right up. it idles kinda bad too low and im now gettin code 43 fuel supply system i dont know if its because of the PR4 ECU. any ideas?
     
    1 person likes this.
  6. roninallout79

    roninallout79 Plan B

    Messages:
    151
    Likes Received:
    0
    Joined:
    Oct 19, 2007
    Location:
    GER friggin MANY
    Get rid of that PR4 get a PM6 if you have trouble finding one PM me I have three PM6's and a PM5 each for 20 bones.

    TRU
     
Verification:
Draft saved Draft deleted

Share This Page